or Connect
New Posts  All Forums:Forum Nav:

MES temp troubles

post #1 of 6
Thread Starter 

I'm having a hard time maintaining temps in my MES 30. I use an Ivation remote digital thermometer to monitor the temps and I'm getting wild swings from 200 to 270 degrees with no, or only minor changes from the control panel. It will be reading 225, then spike to 250, so I cut 10 degrees of the temp from the control panel, and it will drop to 200. Add 10 degrees, back up to 260. Has anyone else had this problem? Is it an issue a good cleaning will solve (it's only a year old, with maybe a dozen smokes on it) or is the element going bad?

post #2 of 6

That's the nature of the beast....   stop changing the temp....   shoot for the middle of the swing...   Don't rely of the supplied temp reading device...  use something like a cabled thermometer, that has been calibrated in boiling water, and place next to the meat....

post #3 of 6
Thread Starter 

Well, I went through my process of elimination and tested my ivation in my kitchen oven. Had the same problem: large temps swings, high readings, etc. Once I began watching it steadily instead of just checking it, I found it was swinging 30 degrees or more in less than a minute without the oven ever kicking on or being opened. Oven was set on 200 and the ivation was going from 210 to 300. Called ivation and they said it's a known problem with the probes. Unit is less than a year old so they are sending out a new probe. 

post #4 of 6
Quote:
Originally Posted by DV242 View Post
 

Well, I went through my process of elimination and tested my ivation in my kitchen oven. Had the same problem: large temps swings, high readings, etc. Once I began watching it steadily instead of just checking it, I found it was swinging 30 degrees or more in less than a minute without the oven ever kicking on or being opened. Oven was set on 200 and the ivation was going from 210 to 300. Called ivation and they said it's a known problem with the probes. Unit is less than a year old so they are sending out a new probe. 


I've said in other threads that I've had my MES 30 Gen 1 for over four years. My unit didn't come with a meat probe (don't need it anyway since that's what my ET-733 is for). For most of that time I've fought the temp swings, too, swings of at least 30 degrees upward from my set point and perhaps 10-15 degrees below when the controller was cycling. Late last year I began to see the controller being more in sync with the temp display on my ET-733. And now, this year I've only done two smokes but each time the controller for the majority of the smoke was within five degrees of my set point or matched it. And...either no swings or swings of just a few degrees. The MES controller is most stable I've ever seen it. The only maintenance I do to keep it working that way is to make sure I wipe off both rear wall sensors: the dime-sized hi temp cutoff switch on the left and the toggle switch-shaped temp sensor on the right. One time when I hadn't cleaned the hi temp switch after a few smokes the MES temp skyrocketed to 295° from my set point of 235°. I opened the door to let out all the heat a couple of times but the temp shot up again. At some point a light bulb appeared over my head and I remembered that dirty MES heat sensors could malfunction. I wiped off the hi temp switch (also cleaning out the notches with a toothpick) and the temp dropped down to normal. Now I always wipe it either before or after a smoke and that high temp spike has never happened again.

post #5 of 6

Hi, let me through my two cents worth in. As Dave said temp. Swings are normal in a electric smoker with the controller that Masterbuilt uses. If you search Temp swings I am sure you will quickly realize you are not the only one with these  issue. Normal would be 20 degrees either side of your set point. Do as Dave suggested look for the mid point. 

Now about your inside oven. 

When testing it you will probably  find there are wide swings in it also. Just the nature of the beast.  Jted

post #6 of 6

Well sir, I have to walk back what I said about the controller in my MES 30 Gen 1 maintaining stable temps. I tried my hand at smoking my first batch of beef jerky yesterday with a temp set point between 160-165°. First off the temp difference between the left and right sides of my MES averaged around 20°. For brief moments they settled in around two degrees of each other. Also, I saw cycling temp swings I haven't seen in a long time. The temps went down around 144° and up as high as 190°. I'd lower the temp when it shot up into the 170s and 180s and then have to raise it again when it lowered into the 140s. Have no idea why this happened. I had 4 racks of sliced beef for the jerky and I had the AMNPS going on the bottom two rails.

 

I'll try my 2nd attempt at beef jerky making in a couple of weeks since there were other mistakes I made that I want to fix. We'll see if the temps swings problem repeats itself.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Electric Smokers