or Connect
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Meat Thermometers › Probe not working on maverick et733
New Posts  All Forums:Forum Nav:

Probe not working on maverick et733

post #1 of 4
Thread Starter 
I put two pork roasts in my cabella smoker. I put a probe in a clip on the grill and a probe in one of the roasts. The probe on the grill looks like it is reading correctly between 220 and 230 degrees. When I put the probe in the roast it initially read 259 degrees. In the last half hour, it has raised to 262 degrees. My wife washed the probes last time we used them and I warned her about letting water get into the probe. If water gets into the probe, will the probe stop working, or will it give false readings? I switched the probes between 1 and 2 and got the same readings. Thanks
post #2 of 4

If you get it wet at the connection it will give false readings.

 

Al

post #3 of 4
Thread Starter 

Thanks, I changed probes (the bad one was in the meat and the good one was on the grill) and it showed the meat correctly and the grill was 279 degrees, what the meat said.  I have to order a new probel

post #4 of 4

I have never tried it, but I have heard people say it might work.  Put the probe in about a 200 degree oven for a couple of hours and see if it will dry out and work.  I have my doubts, but it may be worth a try.  If nothing else you might have a spare probe when your new one arrives.

 

Good luck and good smoking.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Meat Thermometers
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Meat Thermometers › Probe not working on maverick et733