or Connect
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › 1st Gen MES 40 just went cold
New Posts  All Forums:Forum Nav:

1st Gen MES 40 just went cold

post #1 of 8
Thread Starter 
Hey all... I've had my 1st gen 40 inch stainless/window smoker for about 18 months... And it went kaput tonight. I really don't know anything about electrical work, but I can't really afford to just replace the smoker altogether.
The smoker started tripping the breaker during use about 3 months ago, and tonight the heating element went cold mid smoke. Heating light is on, but it won't work.
I have a good feeling that MB won't be too helpful when I call them tomorrow.

I hate to ask you guys to spoon feed me how to fix the wiring in this thing... But I have NO experience rewiring things.
post #2 of 8
Bear Is the gentleman I see answering most MES issues. I wish I could help, but I think he is the one to track down for a hand. Sorry Louis, wish I could be a better help.
post #3 of 8

 The most likely fault is the connectors to the heating element. There is a small cover on the back of the unit on the later ones that allows access to these connectors. The older units called for removing the entire back of the cabinet. 

 This has been a known issue for some time so there are several threads on the issue, some with very good instructions for repair. A search should turn up all you ever wanted to know about this issue. 

 The first step is to remove the cover and see whether or not these are burned up. If you are not very handy at electricity you should look for a friend that is. If the connectors are not burned up you are where you need to be to test the heating element.

 

 Chuck

post #4 of 8

Take a look at this... http://www.smokingmeatforums.com/t/235550/mes40-element-wiring-repair-question  If the wires are still good, the Coil is shot and a call to Masrerbuilt will most likely end with a N/C Coil being shipped even if out of warranty. They sent a new coil to my daughter on a 4 year old MES N/C...JJ

post #5 of 8

Yes MB has very good customer service, they sent a buddy of mine a brand new smoker because his element couldn't be replaced. It was a 4 year old unit.

 

Al

post #6 of 8

I have the same and had the same issue..  i called them and for 20$ replaced the heating element works like new again.. just did it yesterday.

post #7 of 8
Thread Starter 
Well guys, I contacted them and they sold me a new heating element. Unfortunately I installed it and the unit still didn't work. Replaced the connectors... No dice. Took the back off and didn't see any melted wires. Followed the wires to a box on the bottom of the smoker...
She gone.

One of the electronic elements is literally cooked.


MB had originally offered to sell me a shell/cabinet/box whatever for $90 shipped. That was a couple months ago. I hope they still honor that offer.
post #8 of 8
Wow...th_dunno-1[1].gif
Sorry for the bad luck. I hope they still honor it too.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Electric Smokers
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › 1st Gen MES 40 just went cold