or Connect
SmokingMeatForums.com › Forums › Announcements › Messages for All Guests and Members › Need quick help on pork shoulder. This is weird.
New Posts  All Forums:Forum Nav:

Need quick help on pork shoulder. This is weird.

post #1 of 5
Thread Starter 
First pork shoulder but something is not right. I have wsm. I am new but have done other smokes 6 or 8 times with great results. I got 2 8 lb shoulders, boneless. Researched and expected 8 hrs at least and likely 12. It's been 3 and the internal temp is 207! Can't be.

I am using dual temp probe thermometer. It worked very well the first several times so I think it works. I have kept the wsm at 225 to 235 the entire time. I have moved the meat probe between the two shoulders and revoked it several times.

How can it be done. Still looks and feels raw. Even changed batteries.

Help!
post #2 of 5

It definitely cant be done yet.

There has to be an issue with your thermometer.

Try a quick boil test on it or can you borrow a different one??

post #3 of 5
Thread Starter 
I have been in a panic but just grabbed a normal thermometer and it read 117. Whew! Must have a bad Maverick et-733. The probe measuring bbq temp is working but the meat probe is not. I have even switched them. Plus, it's one month old. Suggested by others on this site.

Ok, time to settle in.
post #4 of 5

The probe is under warranty. You should get a free replacement.

 

Al

post #5 of 5
Thread Starter 
Thanks Al. I switched probes and repeated everything. Determined one probe is bad. Now reading IT of 127. Thank goodness. Sorry guys. Just a rookie in panic mode. I will get better.

Thanks for all the advice!
New Posts  All Forums:Forum Nav:
  Return Home
SmokingMeatForums.com › Forums › Announcements › Messages for All Guests and Members › Need quick help on pork shoulder. This is weird.