or Connect
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › MES30 High Temp Problem
New Posts  All Forums:Forum Nav:

MES30 High Temp Problem

post #1 of 10
Thread Starter 

I've had this MES 30 since August 2014 (my second MES).  Just recently I was smoking salmon at 160 and after an hour I went to add some chips and noticed the temp at 275.  Darn fish is now cooked well done.  Next day I checked out the smoker and set it for 100 degrees and after one hour, the temp read 320...I immediately shut it down.

 

I called Masterbuilt and they said I need a new body kit which is about the same price as a new smoker. I did pull the back off and try replacing the thermostat with no change.  It's like the burner is never shutting off.

 

Anyone else ever have this issue?

 

Thanks,

Jerry

post #2 of 10

Sounds like one of the sensors went bad in the body of the smoker. The way the body is insulated under the back panel it could be quite a chore to replace it. Did you try cleaning both the sensors on the back wall of your smoker? If you search PID control in the search bar this may be a option to keeping this smoker running.

post #3 of 10

I agree that you should check the hi temp cutoff switch, which is the round, dime-sized metal thing on the back wall. Mine was once dirty and my smoker temp climbed to 295°. Since then I've made sure I keep it and the temp sensor (the toggle-shaped thing on the back wall) clean and I've never had any more problems. One time I noticed that one of the probes on my ET-733 was up to around 300°. I discovered that a glob of hot fat had fallen on it and that caused the temp spike. When I cleaned off the probe the temp returned to normal.

 

Now it may not be the sensor but it's a place to start and it will cost you nothing to fix if all it needs is a cleaning.

post #4 of 10
Thread Starter 

Checked the the temp sensor and cutout switch.  Cleaned them and no change. Took the control box off my friends smoker and placed it on mine and again no change. I watched the temp rise and the heating indicator actually went out at the temp I set it for, but it's obvious the element never did shut off since the temp kept on rising.  I shut it down when it went 100 degrees above what I had set it for.  

post #5 of 10

There's a problem with the controller circuit...  It's in the floor, back left side...    Probably a relay that hooks to the sensor...   pretty hard to fix unless you are a whiz at electronics....

post #6 of 10
I went with a pid and have never looked back. Temps stay with in +/- 2 degrees all the time. Love it. Much better then the 30+ I was getting and it something goes wrong it easy to fix. Master built controls lack a lot to to be desired Just my .02 worth
post #7 of 10
Thread Starter 

Changed out the control box with my friend's unit last night with no change.  I did notice that when the temp comes up to the temp I selected, the indicator for "heating" goes out.  But the temp continues to rise.  I shut it down after it rose 100 degrees beyond my selected temp (way past the "coasting" temp).  So, I assume the relay that's hidden in the bottom is sticking.  I do work in electronics and replacing that would not be beyond my capabilities. After doing some serious digging in this website and listening to the suggestions about converting to a PID, that just may be the way I go. I'm getting old (and lazy) so I'm leaning towards the Auber WS-1500EPM.

post #8 of 10
Quote:
Originally Posted by fish6735 View Post
 

Checked the the temp sensor and cutout switch.  Cleaned them and no change. Took the control box off my friends smoker and placed it on mine and again no change. I watched the temp rise and the heating indicator actually went out at the temp I set it for, but it's obvious the element never did shut off since the temp kept on rising.  I shut it down when it went 100 degrees above what I had set it for.  


I'd say that your best option is to call MB Customer Service. Your smoker's out of warranty but they might either sell you or agree to ship for free a replacement part. Depending on the costs it might also be wise to check for a really good deal on a new MES 30.

post #9 of 10

Yup for a Auber PID. 

post #10 of 10

The PID is the best choice...  You will have a smoker that works VERY well when the PID is operating....

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Electric Smokers
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › MES30 High Temp Problem