or Connect
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › MES Gen 1 Keeps Turning Off - please help!!
New Posts  All Forums:Forum Nav:

MES Gen 1 Keeps Turning Off - please help!!

post #1 of 13
Thread Starter 

Hello everyone,

 

First time smoking, first time MES owner. I love it. So I'll try to make this explanation as short as possible. I was going to buy a new MES Gen 2.5 smoker per all of your suggestions, but I came across a Gen 1 on craigslist. The gentleman, who I do believe, said he used it twice, and then got a deal on a commercial smoker. I picked up the MESGen1 on Saturday morning, came home, smoked chicken wings, and it worked perfect. The model number is 20070311.

 

It came with a cover, so I covered it Saturday, and it rained Saturday night. I let it dry out Sunday, and was going to smoke overnight Sunday. Well I turned the unit on, and it gave 10 quick beeps and flashes and turned off. Tried it again, it would turn on for about 10 seconds, then beep 10 times and turn off. At this point I brought the unit in my basement to completely dry out.

 

I called MES and ordered a new control unit thinking it had moisture in the control and it had shorted. I got the new control this morning, plugged it in, and right away the same 10 beeps and flashes. I unplugged for 10 seconds, re plugged it in, and got it to turn on, light up, set temp, set time, heat for 5 min, then turn off.

 

Now when I'm testing it, the unit will turn on for say a half hour, jump up and down with temp, and then turn off. I'll test it again, it'll run, reach temp for an hour, then turn off.

 

Is it possible that the NEW control unit I received is faulty, or is there something deeper inside that is shorting out?

 

I am more than happy to provide more info if I can, hell even feel free to call me to walk me through some pointers. But I'm real excited to get going on smoking, only to have this fail.

 

 

Let me know what you think, I appreciate your help.

 

Dan

post #2 of 13
Thread Starter 
I should mention I have this plugged directly to an outlet, no extension cord. Thanks again everybody.
post #3 of 13
There are electronics in the floor... they are probably wet/damp... Bring it inside where it can really dry out... door open... heater pointed at the inside... hope it runs in a couple days.... It will take several days if not longer to dry the insulation out...
post #4 of 13
Thread Starter 

Thanks Dave, I'll try that. So I've tried it off and on tonight, it ran consistently for about 4 hours as I smoked some ribs. I turned it off when they finished, and turned it back on about 15 min later, and it did the same beep a bunch of times, turn off after a few seconds. Turned it back on, heated for a minute then turned off. It's very intermittent.

post #5 of 13
Once it comes on, leave it on at 275 for 24 hours...
post #6 of 13
Thread Starter 

No luck after bringing it inside and drying it out. I took the rear panel off, bought a space heater and had it running for a few days, still no luck. Not sure this can be saved.

post #7 of 13
You can modify it with an external control... Better heat control than the original... Depends on how much you want to spend....

Probably less than $50 bucks and you will be in business....

For some good ideas, start a thread on "How can I modify my MES with new temp controller"... Need Help...
post #8 of 13
Thread Starter 
Dave,

I noticed tonight when I plug the smoker in, without turning it on, there is a hum coming from the bottom. Then when I turn the control on, without turning the heating element on, the hum gets much louder.

Think there is something with the lower power control?
post #9 of 13
Quote:
Originally Posted by Fratalia17 View Post

Dave,

I noticed tonight when I plug the smoker in, without turning it on, there is a hum coming from the bottom. Then when I turn the control on, without turning the heating element on, the hum gets much louder.

Think there is something with the lower power control?

 

 We think alike. That is something you should talk not email about with Master built customer service.   Jted

post #10 of 13
If it's humming, it might be a relay..... Someone on here took theirs apart, showed the parts and what they were.... and I think they replaced the part that was bad...... Can't remember who.... maybe someone remembers that thread and can help you out... I'll be looking too.....
post #11 of 13
Quote:
Originally Posted by Fratalia17 View Post

Dave,

I noticed tonight when I plug the smoker in, without turning it on, there is a hum coming from the bottom. Then when I turn the control on, without turning the heating element on, the hum gets much louder.

Think there is something with the lower power control?


Fully agree with Jted. You need to talk to a Masterbuilt CSR over the phone and not try to troubleshoot in a forum. Since you bought it from the original owner they might not be able to do anything free for you. But your experience just shows why I don't buy stuff off craigslist, especially electronic/electrical stuff. The seller might have known there was an intermittent controller/heating element problem and that's why he was selling it. Don't know how much you paid for it but if you add the cost of whatever replacement electrical components you'll need (and I think you will need them) it might add up to what you were going to pay for that brand new Gen 2.5.

post #12 of 13

If you don't get any help from MB it might be time to check out the lower panel that Dave spoke about. He will give you good advice . Any relays You need to change will be marked as to there type.First try the MB people. This post is a good place to start.

 

http://abcnews.go.com/GMA/recipe?id=10868429&searchtext=magic%20dust&criteria=&page=1

 

Not a relay but a easy fix  if needed.


Edited by jted - 11/5/15 at 11:59pm
post #13 of 13

Mine does this on occasion too.  I'd be interested in your solution, if you found one.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Electric Smokers
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › MES Gen 1 Keeps Turning Off - please help!!