or Connect
SmokingMeatForums.com › Forums › Announcements › Roll Call › I think I have a smoking problem & drinking
New Posts  All Forums:Forum Nav:

I think I have a smoking problem & drinking

post #1 of 8
Thread Starter 
Started a new smoke today on my MES 30. Had an issue about an hour that I thought I would address in case it happens to anyone else. I was managing the temp with the remote and It shut the unit off . When I tried to turn it back on it made a clicking sound like if you had a bad battery in your car.
I couldn't get it back on so I unplug it a realized the GFI tripped. It seems like the remote had something to do with it so I'm doing it manually. Anyone else have s similiar proble with tripping the breaker or the remote?

Pic below of my pork butt. Trying to run it 240 . Cracked my first beer for a 12 hour smoke. Gonna be a long day.

post #2 of 8

There is no reason for the Remote to trip the GFI. The Remote just sends a RF signal to the controller and is isolated from the AC power. Tripping is often a moisture issue where for whatever reason there is moisture in or around the coil. What is unusual is the tripping of the GFI typically happens within 60 seconds of turning it on. If the tripping happened several minutes in and after changing temp, I would think coincidence or flaky GFI, not a remote issue...JJ

post #3 of 8
Thread Starter 
Yeah it's running good now. Thanks JJ.

What's weird now is my probe. The 732 is reading higher than what the MES is reading. In previous smokes it has always the other way around. It is cold out today . This is only my third smoke couldn't probes be messed up already?
post #4 of 8
Thread Starter 
4 hours I at 140
post #5 of 8
Thread Starter 
post #6 of 8
Be watchful of that GFI circuit, 4fun. The reason I smoke with gas now is because I slowly cooked a GFI circuit over two years thinking I was fine. Had to replace 4 outlets...
Trust your remote over the door therm. of course. The whole temperature thing is a mystery to me. Usually I'm fussing to keep below 250, but today it's keeping around 230 where I want it (got a 5# butt in myself). That's where the beer comes in. Gotta do something while watching those temps! On my 3rd Bud myself😀
post #7 of 8

Looking good!  :drool:

post #8 of 8
Quote:
Originally Posted by BBQ4fun View Post

Yeah it's running good now. Thanks JJ.

What's weird now is my probe. The 732 is reading higher than what the MES is reading. In previous smokes it has always the other way around. It is cold out today . This is only my third smoke couldn't probes be messed up already?

 

It seems the Mav Probe responds faster than the temp sensor on the MES back wall. Being off one way or the other is not unusual because they are typically several inches apart. I have 2 MES 40's and Mav 732's one tracks very close the other is 20 degrees off. Go by what the Mav tells you and adjust accordingly...JJ

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Roll Call
SmokingMeatForums.com › Forums › Announcements › Roll Call › I think I have a smoking problem & drinking