or Connect
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › New Maverick Probe Problem
New Posts  All Forums:Forum Nav:

New Maverick Probe Problem

post #1 of 6
Thread Starter 

I was smoking some 1 1/2" thick Pork Chops yesterday. (Sunday) I had my Maverick Probe in 2 of the 8 Chops. I was planning to take them out at 150* One Chop read 149* and the other 144* and they had been stuck there  for probably 15 minutes or so, then all at once their temperature started dropping while the Smoker was maintaining it's 235* temperature. The 149* probe dropped to 144* and the 144* probe dropped to 138*. Then another couple of minutes or so they dropped another 2*.

 

I knew it wasn't possible for the temp to drop when the Smoker was maintaining it's temperature and cycling perfectly, so I  opened Smoker door, pulled the probes out and re-inserted them and the Temp instantly read 151* on one and 149* on the other.

 

Does anyone have any idea how it was possible for the Maverick Probe readings to drop and give a FALSE reading like that?

post #2 of 6

I haven't had them drop like that before. I have gotten funny reading when it was in a fat pocket or too close to a bone. 

 

On another note (sorry to get off topic) pork is considered cooked at 145 degrees. I try to not let lean pork get over that temp. It makes a huge difference in the finished product to keep it as close to 145 as possible. I know my wife always get worried since there is still a hint of pink but it is safe. 

post #3 of 6
Quote:
Originally Posted by Brickguy221 View Post
 

I was smoking some 1 1/2" thick Pork Chops yesterday. (Sunday) I had my Maverick Probe in 2 of the 8 Chops. I was planning to take them out at 150* One Chop read 149* and the other 144* and they had been stuck there  for probably 15 minutes or so, then all at once their temperature started dropping while the Smoker was maintaining it's 235* temperature. The 149* probe dropped to 144* and the 144* probe dropped to 138*. Then another couple of minutes or so they dropped another 2*.

 

I knew it wasn't possible for the temp to drop when the Smoker was maintaining it's temperature and cycling perfectly, so I  opened Smoker door, pulled the probes out and re-inserted them and the Temp instantly read 151* on one and 149* on the other.

 

Does anyone have any idea how it was possible for the Maverick Probe readings to drop and give a FALSE reading like that?


I don't know the answer. What I do know is that with the instant read thermocouple therms we use in our kitchen, quite a few times the temps will drop when we insert the probes into the meat. I've always thought the reason was like what bmaddox posted in that we had inserted the probes into fat pockets since we primarily cook boneless meat.

 

Since you got a higher reading when you reinserted the probes I think bmaddox was right on with his answer. I bet the fat pockets got less dense as they cooked, hence the drop in IT.

post #4 of 6
Thread Starter 
Quote:
 
Quote:
Originally Posted by bmaddox View Post
 

 

 

On another note (sorry to get off topic) pork is considered cooked at 145 degrees. I try to not let lean pork get over that temp. It makes a huge difference in the finished product to keep it as close to 145 as possible. 

I'm aware of the 145* thing, but my wife and I prefer ours in the 155* range. I was following the instructions of the recipe I was using and smoking the chops to 150* per the recipe. 

 

The chops were smoked to perfection to being done to the way we like them, but we didn't like the chops. The recipe called for them to be brined in Apple Cider for at least 5 hrs and it said overnight was ok, and then rinse and apply the recipe's rub and smoke with apple chips to 150*. (I used apple pellets and they smoked really beautiful) However, we didn't care for the sweet taste the apple cider gave the chops and to top it off I did 8 chops planning to freeze some. We will eat 2 more this evening and if we still don't like them, if none of our children want them, I will throw them in the garbage.....sigh :icon_sad: 

post #5 of 6
Quote:
Originally Posted by bmaddox View Post
 

I haven't had them drop like that before. I have gotten funny reading when it was in a fat pocket or too close to a bone. 

 

On another note (sorry to get off topic) pork is considered cooked at 145 degrees. I try to not let lean pork get over that temp. It makes a huge difference in the finished product to keep it as close to 145 as possible. I know my wife always get worried since there is still a hint of pink but it is safe. 


It also depends on the cut of pork. Pork chops,  and pork tenderloin can be considered done at 145° (depends on personal taste) but pork butt/shoulder needs to be slowed cooked to an IT of 195-200°. I'd say the same holds true with pork ribs.

post #6 of 6
Thread Starter 

My chops were center cut butterfly chops ... no bone and no fat other than a thin strip of fat around one outer edge. I had my probes away from the fat.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Electric Smokers
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › New Maverick Probe Problem