or Connect
New Posts  All Forums:Forum Nav:


post #1 of 4
Thread Starter 

For my third effort with the new MES 30 I decided to go with one of our standard recipes - good old pulled pork.   Started off with two pork butts about 7-8# each, these had already had the bones removed when they were packed.    Rinse off, and then rub down with several squirts of yellow mustard, and then coat liberally with my standard rub (a variant of Raichlen's Basis BBQ rub).   Let sit in the fridge overnight.


Early next day, get the MES 30 and the AMPS going.   For this setup, I wanted to get the AMPS up off the floor of the MES, and I had the room to do it because I only had the 2 butts to smoke.  So the AMPS - filled with a mix of Pitmaster's Choice and Apple - went on the lowest rack, and on the next rack up I placed a small sheet of foil just big enough to act as a drip guard over the AMPS.  Then the butts went on the upper two racks.


Set the MES30 for 220F and let it go to work.  At 8PM, after ~12 hours, the butts were still hanging around the 160F collagen plateau, and I knew it was going to be a while . . .  so I set the MES30 timer to shut off at 1:30 AM and called it a night.    My guesstimate was that this should get the butts to up around 200F and then they would have time to cool a bit before . . .


Getting up at 4AM to pull the pork before going off to work!  When I went out to get them, the internal temps were at ~150F and chamber temp was 105F.   Here's what I found:



The butts pulled nice and easy, and so I think the internal temps probably did get to the ~200F range, just based on feel.    Pulled pork is great because it freezes so well in nice 1-2 meal size batches, so we had some fresh that night and also put some in the freezer for later.


The Good:   very simple and easy to do, and the MES makes these long smokes (almost 18 hrs in this case) easy, whereas the old CharGriller would have needed a couple bags of charcoal and LOTS of tending to, and somebody would have had to be staying up all night to do it. 


The Bad:   I'm still having issues with the AMPS staying lit and burning the entire length of pellets.  I've tried different locations in the MES, different levels of pellets in the AMPS, and I've been pretty aggressive about really lighting it up with the torch and giving it the 10 minutes to burn before putting the flame out.    But it still is not predictable/reliable, typically going no more than 2-3 hrs before dying out.   And these butts did not have the smokiness that I've typically gotten on the CharGriller, and I think that is because the AMPS was only working for maybe 10-12 hours of the smoke, if that.   The exterior of the butts looked great - but the smoky flavor wasn't quite up to what I expected.


Clearly I need to do some more research and testing . . .  :33: 

post #2 of 4

are you pulling the woodchip tray out and removing the tube feeder completely? And the vent wide open?

post #3 of 4
Try getting Farmer to help ,he has a mod you could u se.
post #4 of 4
Thread Starter 

I've been keeping the vent open, but have not tried removing the chip tube, which I assume provides added airflow.   I'm going to be running 10# of bacon this weekend and will give that a try.


Thanks for the tips!

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Grilling Pork