or Connect
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › Long Time Lurker....MES Popping GFCI when plugging in
New Posts  All Forums:Forum Nav:

Long Time Lurker....MES Popping GFCI when plugging in

post #1 of 5
Thread Starter 

Had this smoker for 4 years of heavy use with an AmazN tray. Used wood for years before buying this MES. Well..... I have had a Big Chief for 25 years, I still use from time to time doing fish and jerky but I Been very happy with the MES for the ease of use. Anyway......It's a 30" Gen 1 digital. So I wanted to smoke a ham overnight and I go to plug it in and it instantly "pops" the Gfci breaker. I use this outlet all the time with it as it sets on my covered deck. I tested the outlet by plugging in my 2 hot air popcorn poppers I  keep out there (I roast my own Green Coffee beans with them) and they work just fine as the 2 together pull about 2000 watts.  (Which you can smoke your coffee beans then roast and it gives the beans a very subtle smokey flavor....another story for another time)

 

As soon as you plug the MES in it trips the breaker. Would it be Heating element short that causes this even though it happens just plugging it in? Moisture in the digital controller as we have had tremendous amounts of rain but the deck stays pretty dry, thoughts?

 

Then after I pull it apart in the morning and if I can not sort it out......worth repairing since I am unsure what it is the cause and just save it as a pure cold smoker. Then just get something else which if needed will but just don't want to waste the cash if don't need to......

post #2 of 5
Pull the small cover, low center of the back of the smoker off, and check the wiring to the heating element....

You can bypass all the electronic stuff, and use a temp controller of sort, and have it running in a few hours...
post #3 of 5
Quote:
Originally Posted by DaveOmak View Post



You can bypass all the electronic stuff, and use a temp controller of sort, and have it running in a few hours...

That is a great idea. If you can't figure out the problem you can switch to a PID controller which will set you back about $150 (or $50 if you can build it yourself) and should have you back up and running in no time. 

post #4 of 5
Quote:
Originally Posted by davemhughes View Post
 

Had this smoker for 4 years of heavy use with an AmazN tray. Used wood for years before buying this MES. Well..... I have had a Big Chief for 25 years, I still use from time to time doing fish and jerky but I Been very happy with the MES for the ease of use. Anyway......It's a 30" Gen 1 digital. So I wanted to smoke a ham overnight and I go to plug it in and it instantly "pops" the Gfci breaker. I use this outlet all the time with it as it sets on my covered deck. I tested the outlet by plugging in my 2 hot air popcorn poppers I  keep out there (I roast my own Green Coffee beans with them) and they work just fine as the 2 together pull about 2000 watts.  (Which you can smoke your coffee beans then roast and it gives the beans a very subtle smokey flavor....another story for another time)

 

As soon as you plug the MES in it trips the breaker. Would it be Heating element short that causes this even though it happens just plugging it in? Moisture in the digital controller as we have had tremendous amounts of rain but the deck stays pretty dry, thoughts?

 

Then after I pull it apart in the morning and if I can not sort it out......worth repairing since I am unsure what it is the cause and just save it as a pure cold smoker. Then just get something else which if needed will but just don't want to waste the cash if don't need to......

Dave walked me through the change over to a PID controller.It is viable solution. If you want to check out what you have it is not hard and the fix can be very easy. Most likely you won't even need a multi meter..

What you need to do is to connect the smoker up to a non GFCI outlet. If you have to use a extension cord keep it short and use a 16AWG cord For a short period of time. You really should have a size 14AWG cord to run it but you are just checking the smoker to see where the problem lies.  If the smoker  heats and the controller sets up this is a good thing. 

You have just eliminated the element controller and the electronics as possible problems.

Let's assume the smoker works connected to a normal outlet. 

If every thing works as usual this probably means your GFCI is picking up a slight ground.The easy fix will require removing the entire back of the smoker . This sounds like a big job but it is not However you will need to replace the 25 or so rivets you will drill out ( have on hand at least 2 -1/8" bits ). What I used to replace the rivets were #8x 1/2 " Phillip truss head self tapping screws. A truss head screw has a slightly larger head sort of a built in washer for support.

 

 

While you have the back off you can take a look at the connections at the element. there are 3,  visually check  the connections, being loose or burning are not uncommon. Corroded wire connections are repaired easily this includes the green connection  at the element plate. After checking the connections you need to follow the ground wire to the right lower side and remove it from the smoker and clean the connector and the smoker connection as I recall it was a screw or screw post. Now that it is clean reassemble the ground and install the back. Your grounding problem should be solved. If you element connection are looking bad just remember to replace them with Hi Temperature connectors. They will be steel or nickel steel with no insulators on them. they are not available at big box stores. Generally you need to get them from someone who repairs Appliances or a good hardware store. I bought mine at a large Ace store, that sold elements.     Jted


Edited by jted - 5/29/15 at 9:42am
post #5 of 5
Thread Starter 

Thank you very much and this gives me a pathway to head down.

 

A new one is about $170 so anything over $100 to repair and I will just replace.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Electric Smokers
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › Long Time Lurker....MES Popping GFCI when plugging in