or Connect
New Posts  All Forums:Forum Nav:

Maverick ET-735 Issues - Page 3

post #41 of 57
Originally Posted by TJohnson View Post

I keep reporting any issues found to Maverick

They have told me to tell members to update the app

i tried that but there is no update at Google play. i have always had version 1.2 same version on Google  play

is there another version somewhere else or is this there way of showing they don't know how to fix it. Also i cannoy find an install it on my tablet galaxy note 10.1

Edited by dreadylock - 5/31/15 at 12:29pm
post #42 of 57

seems a cop out by the manufacturer telling the end mug user to update the software when there is no update available!!

post #43 of 57

Just received my Maverick ET-735 last week (ordered off of Amazon....should have ordered from a Forum member). I wanted to use it with my new UDS builds that we are completing, and had really high hopes for this product. Unfortunately, it appears i have been let down. I can't seem to get the app to connect with the transmitter, and when i do, it tells me there are no probes connected.  The fact that it ships without an instruction guide, is pretty comical (as how can i read an instruction manual on my phone, while fumbling through app and phone settings. My only regret is that I didn't keep the box, so i could return the product (tossed it in a bit of drunken competition bbq rage). I might try it with another phone or two (I was trying to use it with a Samsung Galaxy S5 Active....and got no love), just to see.....but as of right now, i am not impressed at all.


I did breakdown, that same day after discovering the ET-735 may be more hassle than it is worth given the software, and purchase an ET-733. I fired that up right away, and had no issues. However, several at the BBQ comp that I was at told me that they can't use wireless mavericks because they will pick up other competitors sensors. That exact issue was what i was trying to avoid by purchasing the ET-735 (well that and being able to monitor 4 probes would have been cool).


--Matt Tucker

post #44 of 57

worst maverick device yet

i get no device and sometimes probe disconnects with new version 1.5

sammy note 5. i think i'll just chock this one up to fail device and try a igrill2


thanks to all

post #45 of 57
Originally Posted by MattTucker View Post

I did breakdown, that same day after discovering the ET-735 may be more hassle than it is worth given the software, and purchase an ET-733. I fired that up right away, and had no issues. However, several at the BBQ comp that I was at told me that they can't use wireless mavericks because they will pick up other competitors sensors. 


--Matt Tucker

I don't think that is correct. I regularly run 4 or 5 ET-732/733s together and once they are initially paired when you switch them on they stay paired. I have never has a problem with them connecting with other pairs. I was in Grillsock a few weeks ago in Bristol (a large UK BBQ event) and most of the competition teams there were using Mavericks.

post #46 of 57
Thread Starter 

I have battled with mine since the week they shipped.  The key for me was the phone I was using.  The Android simply does not work.  However, on my iphone 5 and iPad mini (v.1) it works fine. 


I use it with all four probes plugged.


this last week a new problem emerged, my 3rd port no longer reads correctly, it says - 5 F.  Which I am sure is wrong as I live in the desert in Arizona.


Battery life is pretty darn good I have to say.  I have left it on for a day several times and it still works.  only changed batteries 1 in last 4 months.

post #47 of 57

what kind of range are you getting on it? and what android phone(s) did you try? seems like at least a Samsung compatibility issue, if not more from what I have read.

post #48 of 57
Thread Starter 

Yes, I have Samsung devices, and S5 and a Tab 3.  it just doesn't work with those.


Range from iPhone and iPad is average of 30 feet with up to 40 at times.

post #49 of 57
plimtuna, glad to hear that you were able to reinstalled on your tablet and it's working fine, I can totally understand the frustration you were going through! As for me I'm sticking with my Maverick ET-733 no problems so far. As always Happy Smokin' yahoo.gif

post #50 of 57

I was really excited to get this from Todd.  Sort of a "Xmas gift for me!" Unfortunately, I am having similar issues. I am running Andriod 5.1.1 on a oneplus1 phone.  I have not tried it on an idevice, but after reading this thread, I will try that along with maybe a tablet or two and report back. 


My main reason for the purchase was really the 4 probes. I dont see any other Mav's with that ability. Also the fact that it will support swapping probes with my existing 732 and the hybrid ability.


The issue I run into is it does not seem to want to connect.  The version of the App is 1.5.


Hopefully Todd can shake up the Maverick folks!  yes, I totally agree, WIFI would be amazing!  


There is a bbqguru cyberq that runs WIFI but that is 400 bucks! (As much as my MES40)





post #51 of 57

I almost bought one from amazon, it was their deal of the day for 50 bucks.... but I just couldn't knowing the issues people are having with them. I need about 75' of range, or at least the ability to connect at the very least and I can craft a workaround. but drops and people having issues connecting at all ruin it for me.


I really need a new thermo also, as my 732 is on its last legs due to abuse and my 733 is on the fritz for some reason (keeps on losing signal).

post #52 of 57

So here is an update.  I have tried with 4 devices now.  The only one that consistently works is a Samsung S6 running Andriod 5.1.1


The other devices include an ipad mini running 7.1.2 ios, the one plus 1 running 5.1.1 and a Google Nexus 7 2013 version running 5.1.1.


It would be great to get the other devices running . I do see on the Maverick since that they list devices compatible. 




It makes no sense why my other devices, especially the ipad mini does not work!


I will continue to test a bit more.  Hopefully Todd can pass this to the rep!





post #53 of 57

I have called Maverick 3 times.  They have not been able to fix, and the person they were escalating to has not called either.  We might have a thermometer going back. :

post #54 of 57

no word from Maverick. Going back.  I guess I will save up for a cyberQ!  Let me know how I should proceed Todd!

post #55 of 57

No word on a return yet :(  On a whim, I grabbed an old Samsung S4.  It worked as well. Somehow, this is locked into Samy and iphones.  And only certain ones. I did notice they have a list on the website now.  If I would had seen this before, I would not have jumped at it.  Even at the great deal I got from Todd and Amaze-N-Smoke.





post #56 of 57

Will not pair up with my iPad, does every now and again with my IPhone 4s.. Pairs up fine with my wifes Samsung tablet but shows "probes" not connected.. This is my second weekend using it and I'm done with this piece of crap... I believe the problem to be with the transmitter.. Going back to the 732, it was reliable and accurate, with refreshed temps and worked anywhere in my house.. Blue tooth is junk on this piece of crap...

post #57 of 57

mine worked for a whole day! after a year! when i updated to the new version of software so i bought another 2 probes for it..then it has not worked since..same problems..total piece of junk, the really bad point it you cant adjust any temps without connecting to it so it is actually worse than useless as you cant even use it as a standalone device

no more Bluetooth wireless probes for me ever!!!

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Smoking Gadgets and Tools.