or Connect
New Posts  All Forums:Forum Nav:

Over my MES 40''

post #1 of 7
Thread Starter 
for christmas i received a MES 40 incher. Anyway, on to the real issue. The smoker, I was in touch with masterbuilt on several occasions and even had the unit replaced. THE TEMPS NEVER MATCH my own grate temps. I mean 40-90-100 degrees off. I woke up today 6am (wanted up at 5) because i knew i had to get 18 pounds of pork in there for tomorrow afternoon.  Anyway attached is some pics.Any thoughts on how i can QUICKLY drop the temp? I thought maybe a COLD ice pack pressed against that stack of dimes in the back? Or is it the little probe sticking out? I need to keep the temps close to where they are and reset the stupid controller.

Edited by will75 - 4/4/15 at 7:01am
post #2 of 7
Thread Starter 

2 more pictures

 

and a 2nd redi check for verification

 

and in case masterbuilt blames the redi chek, here is there own meat thermometer which is placed on the side of the machine in their little holster in the machine


 

and fyi this unit it less than 2 months old..

post #3 of 7

Are you going by the MES temp? looks like your Maverick has the temp at 176.

post #4 of 7
Thread Starter 

Maverick is correct, like it always is. So that's telling me my MES is 100 degrees off? This is my 2nd unit that can sometimes be 60-100 degrees off. 10-20 is fine. but 60-100? I am essentially screwed unless i can get the MES to reset and start heating again

post #5 of 7
Quote:
Originally Posted by will75 View Post
 

Maverick is correct, like it always is. So that's telling me my MES is 100 degrees off? This is my 2nd unit that can sometimes be 60-100 degrees off. 10-20 is fine. but 60-100? I am essentially screwed unless i can get the MES to reset and start heating again

Adjust from your set temp on the MES, if you set at say 225 jack it up to get the temp on the Maverick

post #6 of 7
Thread Starter 

mes wont go over 275degrees. problem is. it thinks it already is at 280 but it's not.I have extra parts from Masterbuilt. I just switched out the digital top part and the temps still read the same, although after opening it, it dropped down to 230 and it's reheating.Maverick is around 160's.

 

 

Edit. Just checked it. Now Maverick is 190 on rack, and the MES is 250. So it seems it's starting to correct itself. Not completely, but it's starting too. Now if i can just get it to 225-230 i'll be set, screw it.I won't open it and just use the chip trap instead heh.

 

 

 

edit 2...  284 MES

 

 

194 maverick. sigh not sure how to go about this.Just leave or what.


Edited by will75 - 4/4/15 at 8:17am
post #7 of 7

Don't know what to tell ya I am on my 3rd control panel Get as much smoke in as you can finish in the oven Good Luck

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Electric Smokers