or Connect
SmokingMeatForums.com › Forums › Smoking Meat (and other things) › General Discussion › Need help with A-MAZE-N-SMOKER, its driving me crazy.
New Posts  All Forums:Forum Nav:

Need help with A-MAZE-N-SMOKER, its driving me crazy.

post #1 of 17
Thread Starter 

This is driving me crazy. Im ready to just throw the dang thing in the garbage.

Ive tried smoking a handful of times now with it and cannot get it to work properly.
Ive emailed with the owner and still cant get it right. The self igniting torch head I got also broke the 3rd time out (not his fault) but its just adding to my frustration. lol.



-I follow everything to the T. I even let everything go longer (starting the pellets, letting the flame burn, etc) This last time around I microwaved the oak and maple pellets for about 2 minutes to try and dry them out.
-Its placed in the normal position that everyone has it in their mes30
-Chip  tray removed

-Chip Loader moved out a bit (have also tried all other distances including completely out)



So far, this time as worked the best. But when I opened up the smoker, the maze had been dead for a while, stopped halfway. Nothing was changed or adjusted. The pellets were even height in the maze.

Im ready to go back to using regular wood chips and shavings.  But I bought this so I could smoke overnight....


Edited by rtpassini - 1/4/15 at 2:43pm
post #2 of 17

I've not had too much trouble with my AMZNPS, I always microwave my pellets for 1 minute give them a rest for a bit and then for another minute.  This seems to dry them out much better.  It is important to allow them to get a good burn started, 10 minutes seems to work best for me.  If you do all this and it still goes out it is an airflow issue.  Hope this helps.



post #3 of 17
Thread Starter 

I let them burn for 15 minutes just to make sure its really good, then I blew the flame out. Like I said, it went halfway no problem then stopped?
If nothing was changed or adjusted, why go out? Airflow wouldnt just stop unless I closed something up.

post #4 of 17
try this the next time... put the pellet tray (full of pellets, not lit) in the smoker while it's preheating.. get the pellets and tray warmed up with the smoker... take it out and light it when you put the meat in ...

Also... do you have some kind of cover over the tray to keep grease and juices from dripping in it and putting it out ??
post #5 of 17
Thread Starter 

Thats a good suggestion, I'll give that a go.

Also, yes, I do have a drip tray. So that isnt an issue

post #6 of 17
Because I'm impatient I have used a heat gun to get it going after I get it lit.
post #7 of 17
Are you using the water pan? I had a Cajun injector which was based off the mes30 design. My amnps would not burn correctly if I used the water pan. Once I filled the pan with sand, I quit having issues. The large pan was putting too much moisture in the air and was smothering the amnps.
post #8 of 17
Thread Starter 

Nope, The only "liquid" that is in there are drippings

post #9 of 17
Thread Starter 

Also, I relit the pellets and it burned the rest of the way...maybe there was a spot that wasnt dried well enough?
I dont know.

post #10 of 17
I know you said that there is no way any moisture dripped on the maze. I had some issues with mine when I started and thought the same. But on a whim I made a tent of foil over mine so that "just in case". I have not had any issues since. It only takes 1 drop sometimes to kill the burn. The MES smokers do not let a lot of moisture out, so drips happen. I don't go through the microwave process, just lucky I guess.
post #11 of 17
Next time you might try microwaving them as Bear suggested. I have read where some people will even spread the whole bag of pellets on a large cookie sheet and "bake" them for an hour, then put them back in the bag. I just keep mine in the original bag in the house so they stay dry.
post #12 of 17
Mailbox mod. Zero issues after that.
post #13 of 17
Thread Starter 

so, while looking at the mailbox mod, the ENTIRE chip tray was removed...is that how its supposed to be? I thought just the bottom tray type thing should be taken out

post #14 of 17
Try this link. It has some good info and pics of mailbox mods to mes30s.

post #15 of 17

 You don't have your location in your profile so I thought I would mention that high elevations can cause the problems you are having. I dry my pellets and keep them in air-tight containers so they are ready to use. I have been playing with the tube smoker lately and I think I am going to like it better than my 5x8. More smoke and no problems keeping it burning.



post #16 of 17
I have a tube smoker also and no problems here!

I don't microwave or prebake my pellets. I don't even do the ten minute burn thing. I light it, blow on it a couple of times and into the smoker...

I use the 12 inch tube, I recently got the 18 inch one but haven't used it yet, and if I'm doing a smoke longer than four hours I will grab the tube near the end of the four hours and pick it up and shake the ashes out and get all the lit pellets at the end of the tube and refill with new pellets and it will burn back the other way for another four hours!
post #17 of 17
I tried everything in my mes 40/amazn pellet smoker with very mixed results. I had success and failure all mixed in. Finally after worrying about it all the time I said screw it and bought a mailbox and some dryer vent tube. Now I have zero issues. It's not worth the headaches. Just add a cheap mailbox mod.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: General Discussion
SmokingMeatForums.com › Forums › Smoking Meat (and other things) › General Discussion › Need help with A-MAZE-N-SMOKER, its driving me crazy.