or Connect

smoker box question

post #1 of 4
Thread Starter 

I have a masterbuilt non-digital smoker and I love it. The only thing I would like to improve on and may have a solution too is the smoke output and use of the chip. I find that after an hour or 2 the smoke output is just about gone, but when I go to ad chips...the old one in the box are just black and not ash. When I dump them out...they start to smoke and glow again. I think the smoker box cover is not letting enough air in to be efficient. The question I have is....should I leave the cover off and let it go like that? If I did should I soak the chips or not so they don't flame up. Or.....should I not fill the box as full and change more often?

Thanks,

John

post #2 of 4

I, and like others, have found that the problem is that once your smoker gets to temp, the heating element turns off. This causes a insufficient amount of heat for the chips to stay ignited. 

Also, the reason the chips are black, not grey, is because they are not getting enough oxygen for a full burn.

Because you have an incomplete burn, the black chips that you have leftover are basically charcoal and the smoke flavor is bitter.

 

This is why many posters on this site have have raved about the amaz'n pellet tray/tube.  You will always have smoke, even if the heating element is on/off

 

Do a search for "analog" and you will see more info on your type of smoker and modifications that others like me have done.

 

-Brian

post #3 of 4

I agree with Brian.

Happy smoken.

David

post #4 of 4
Thread Starter 

Thanks for the replies! Sounds like a great idea and I will look into it. Today I am smoking a turkey and I left the cover off the smoker box and filled it. Just checked on it and I am getting full smoke....so much so that when I opened the door I had to stand back for a second. When I looked at the box there was starting to get ash, so it looks like that mat work for now! Thank you!