or Connect
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Pellet Smokers  › A-Maze-N Smokers › amnps does not stay lit
New Posts  All Forums:Forum Nav:

amnps does not stay lit

post #1 of 33
Thread Starter 

Looking for some input on my amnps problem. I've tried 2 brands of pellets, 1 brand is from the amnps website, and neither stays lit.


I put the pellets in an oven for 45 minutes at 300 degrees, start the pellets with a butane torch, use a blow dryer to really get the pellets going, and let them burn for 10 minutes before putting them in my mailbox mod.


I've even left the amnps sitting on the garage floor and it still struggles so it does not seem to be an air issue.


Elevation is about 880 feet in portage mi.

post #2 of 33
What smoker are you using it in?
post #3 of 33
Thread Starter 

It's an electric 30 gallon ugly drum smoker with a mailbox mod on the side of it. I can post pics but not till tomorrow. I'm using the flat lid with 2 stacks about 1 1/2 inch diameter.

post #4 of 33
Any vents in the mailbox?
post #5 of 33
Thread Starter 
Yes. About 10 three quarter inch holes. I started out with a couple and since have added more hoping to fix the problem.
post #6 of 33
Post some pics when you get a chance.

The set up sounds good to me.
post #7 of 33
The UDS is probably cold and there is no "natural" draft going on there.. Do you have a fire built in it.... If so, you need more exhaust openings... also try closing the air inlets to get more suck through the MB mod... It has to be an air intake problem...
Also you could try lifting the UDS off the ground a foot or 2.... get it higher than the MB mod... chimney effect may help a lot....
post #8 of 33
I read where some types of pellets are harder to stay lit than others. If you are using one of those types you'll prob need to do a mix of different pellets to keep them lit.

I personal use either pitmaster choice or traeger "hickory" pellets in my amnts and only once did it go out.

You don't mention which pellets you are using and that might help.
post #9 of 33
I'm voting air draw on this one. I have no problems keeping my AMNTS lit in mailbox when attached to the UDS. I attach mine through one of the intake vents. I leave the lid vents (2" and 1" round bung openings) open. I usually close the other two inlets.

Are you sitting the AMNPS directly on the bottom of the mailbox? If so I'd crumple some tinfoil balls up to get an air gap between the AMNPS and the mailbox.

As Dave mentioned if the UDS is super cold draw may be a problem. One or two lit briquettes in a tin can placed in the UDS for 15-20 minutes could help.
post #10 of 33
Crush a handful of pellets and mix the dust in with the whole pellets. That will keep things burning after you lite them up. I couldn't keep my strainer mod lit until I did that and now it burns perfectly.

post #11 of 33

That smoke looks alittle too tinted brown for my liking. I hope it evens out after an initial burn.

post #12 of 33
Thread Starter 

ok. here's the setup...


30 gallon drum in a 55 gallon drum with perlite between the two for insulation. The exhaust stacks (two of them) are 1 3/8 inner diameter. The intake for the mailbox mod is 1 3/4 inner diameter. It has a pid controlled brinkmann electric element.


Welshrarebit...I've tried pellets directly from the amnps website (hickory), smokehouse (apple), and camp chef (hickory).


post #13 of 33
Nice smoker!

I'm pretty sure hickory and apple weren't the ones that had issues staying lit.
post #14 of 33
Thread Starter 

It's ugly but I want to fix any bugs before making it not as ugly!


All three brands are acting about the same so i'm thinking it's not a pellet issue.

post #15 of 33
Thread Starter 
Originally Posted by DaveOmak View Post

also try closing the air inlets to get more suck through the MB mod... It has to be an air intake problem...

It did seem to do better with less intake holes. I'll try blocking some off and see what happens. Maybe I started with to much intake to start with??

post #16 of 33
OK, I see one problem..... recirculating smoke has less oxygen than fresh air.... the oxygen has been consumed by the chips making the smoke.... the smoke should exit out the end of the MB.... air in one end, smoke out the other.... no chance for the smoke to recirculate... My MB mod.... I use a 3" duct for the smoke.... don't know if a smaller duct makes a difference... try a modification with the smoke exiting out the end of the MB.....

post #17 of 33
Thread Starter 

I will give that a shot.

post #18 of 33

I too have the inlet at the door end and the outlet at the back of the mailbox. I also use 3" dryer vent, which gets reduced down to 1" for the UDS connection, 3/4" for the mini-wsm.



post #19 of 33
Thread Starter 
It's pretty cold here in michigan. I wonder if insulating the mailbox would help. I changed the setup and it stays lit so far but slow and minimal smoke.
post #20 of 33
I'd try making the joiner between mail box and smoker bigger.
The other boys air has time to cool before reaching the cc, yours doesn't so could also be hindering air flow
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: A-Maze-N Smokers
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Pellet Smokers  › A-Maze-N Smokers › amnps does not stay lit