or Connect
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Smoking Gadgets and Tools.  › First time using AMNPS in my MES 30...had issues staying lit
New Posts  All Forums:Forum Nav:

First time using AMNPS in my MES 30...had issues staying lit

post #1 of 5
Thread Starter 

Not sure what my problem is here. I followed all the suggestions that I found.

 

I did 2 chickens set at 275.

AMNPS in the lower left with the chip holder removed

I played around with the Chip Loader from shut to removed and it didnt seem to make a difference.

The first round I had it so well lit the whole first was done in like an hour. lol. I was able to calm it down a little bit and it was good. Then for some reason died out. Got it going again and it went out (again playing with the chip loader position)

I dont know if this would do anything, but this is my setup for being to smoke during snow storms and rain.

It just vents outside, I cant imagine that changes anything.

post #2 of 5

If your altitude is NOT 5000 feet or higher, then it is either:

 

1. Insufficient airflow (unlikely with your chimney setup).

2. Incomplete lighting process (need to get a better bed of hot burning pellets going).

3. Pellets which are not fully dry (microwave them first to drive out residual moisture).

4. One of the notorious pellets for keeping lit (such as cherry).

 

If altitude is your issue, switch to their tube smoker, as versus the tray.  The tube stays lit at altitudes of up to 10k feet.

post #3 of 5

yeahthat.gif

Happy smoken.

David

post #4 of 5
Thread Starter 

Well, im 843 feet above sea level...so thats not it.

Maybe they werent dry enough? I'll have to try that next time. I also was using maple.

post #5 of 5
Get rid of the water pan.... the steam chokes out the fire... When the tray of pellets burned up quickly, you had the smoker too hot...

Smoke the food at around 140 ish, then turn up the heat to cook....
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Smoking Gadgets and Tools.
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Smoking Gadgets and Tools.  › First time using AMNPS in my MES 30...had issues staying lit