or Connect
SmokingMeatForums.com › Forums › Smoking Meat (and other things) › General Discussion › Model #ET-73 Remote Smoker Thermometer HHH Error
New Posts  All Forums:Forum Nav:

Model #ET-73 Remote Smoker Thermometer HHH Error

post #1 of 4
Thread Starter 

Can anyone speak to this error I'm seeing on my remote unit?  It's my 3 time using it and I'm pretty frustrated to pay 60 bucks and already have a malfunctioning product.  It displayed HHH and then a wildly high temp, cycling back and forth between the two.  A couple times it looked to be legit.  Anyone with similar experience that would care to comment?

post #2 of 4

The simplest answer would be to check that you have the plug all the way in. The next would be to try fresh batteries. The batteries that come with the unit are junk and who knows how old they are after sitting in some shipping container or warehouse for maybe years. The last would be a bad probe. Occasionally they come with a bad probe. Normally they will send you a new probe if that is what it is at no cost. I have had all of the models they make and have only had that problem one time and it was a bad probe due to me running it through the dishwasher. Never do that. Never soak the probes in dishwater either. Moisture will seep in and short it out. If it is a dual probe unit switch the probes to try and isolate what is going on. Do not give up and call the vendor where you got it if you need to. I have heard nothing but good things about customer service from maverick.

post #3 of 4
Thread Starter 
Quote:
Originally Posted by timberjet View Post
 

The simplest answer would be to check that you have the plug all the way in. The next would be to try fresh batteries. The batteries that come with the unit are junk and who knows how old they are after sitting in some shipping container or warehouse for maybe years. The last would be a bad probe. Occasionally they come with a bad probe. Normally they will send you a new probe if that is what it is at no cost. I have had all of the models they make and have only had that problem one time and it was a bad probe due to me running it through the dishwasher. Never do that. Never soak the probes in dishwater either. Moisture will seep in and short it out. If it is a dual probe unit switch the probes to try and isolate what is going on. Do not give up and call the vendor where you got it if you need to. I have heard nothing but good things about customer service from maverick.

I checked the plugs right away.  I will replace the batteries and see what happens.  Crossing fingers that it's that simple!  Thanks so much for your response.  Good to know that their customer service is positive as this is kinda rare these days. no pun intended. haha :icon_lol:

post #4 of 4

Jet , obviously , had your problem and you can too :icon_exclaim: If worst comes to worst , pack the whole thing , with a letter , and send it to the Mav. people to check , and most likely , they will send a new unit.

 

I melted on down and sent it in to show them I wasn't trying to lie about it , they were friendly and promptly returned another...

 

Hope you get it straight soon , and as always  . . .

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: General Discussion
SmokingMeatForums.com › Forums › Smoking Meat (and other things) › General Discussion › Model #ET-73 Remote Smoker Thermometer HHH Error