or Connect
New Posts  All Forums:Forum Nav:

MES issues

post #1 of 4
Thread Starter 
[/SIZE
Hi All.... New to MES ( 40" w window) and new to this forum. Smoked 5 lb pork shoulder yesterday. 11.5 hours at 225, stooped at dark w internal temp of 193, and it had zero bark. Did not use water pan. No real smoke flavor either . Have made bigger n better shoulders on my charcol Webber. What is the deal? Feel in like I wasted my paycheck on this. Any thoughts please? Ty, Connie Ly
post #2 of 4
Quote:
Originally Posted by Connie Lu View Post

[/SIZE
Hi All.... New to MES ( 40" w window) and new to this forum. Smoked 5 lb pork shoulder yesterday. 11.5 hours at 225, stooped at dark w internal temp of 193, and it had zero bark. Did not use water pan. No real smoke flavor either . Have made bigger n better shoulders on my charcol Webber. What is the deal? Feel in like I wasted my paycheck on this. Any thoughts please? Ty, Connie Ly

 

Sounds like everything worked pretty good, except for the smoke.

 

The chip burners in electric smokers are not a good way to produce smoke---They get a variable amount of smoke, between Zero & too much smoke. There are a few good smoke generators on the market, but the favorite on this forum, including mine is the Amazing "AMNPS".  Once you learn how to get it lit properly, you can load it with wood pellets, light one end, put it in your smoker, and enjoy perfect smoke for up to 11 hours without touching it.

 

 

Bear

post #3 of 4
Thread Starter 
Thanks Bear... Will give that a go this coming weekend
post #4 of 4
Quote:
Originally Posted by Connie Lu View Post

Thanks Bear... Will give that a go this coming weekend

 

Here's a link to the AMNPS:

 

http://www.amazenproducts.com/ProductDetails.asp?ProductCode=AMNPS5X8

 

 

Bear

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Pork