or Connect
SmokingMeatForums.com › Forums › Smoking Meat (and other things) › General Discussion › First smoke - newbie question
New Posts  All Forums:Forum Nav:

First smoke - newbie question

post #1 of 4
Thread Starter 
Hi guys,

Starting my first smoke and have a few questions....

I am smoking with a brand new Weber smokey mountain 22.5, I have temp probes in the pork butt and clipped the probe right under the top grill (pork butt is on the top grill).

Problem is that the factory weber probe is reading 260F and the probe is reading 207F...do i have the probe set at the right spot? Is it normal to have such a large difference in readings?

Cheers,

Knife
post #2 of 4

Hello.  A little more info would be helpful.  What kind of therm are you using ( probes )?  Did you test the therm probes before starting the smoke?  Is the chamber probe touching any metal?  Is the clip  properly placed on the probe?  As a "general" rule the answer is yes.  The therms that come with all smokers are notorious for being incorrect.  Not saying your's is one of these but would not be surprised to learn it was off.  Keep Smokin!

Danny

post #3 of 4
Thread Starter 
Hey Danny!

Probe I am using is a Maverick ET-733. It is clipped on right. Changed spots to top rack and clipped on the top (previously had it clipped under and noticed meat juices where dripping on it...oops).

Temp right now on the weber is at 235F, and temp on the probe is reading 262F.

Cheers
post #4 of 4

Hello.  Go with the Maverick.  Keep Smokin!

Danny

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: General Discussion
SmokingMeatForums.com › Forums › Smoking Meat (and other things) › General Discussion › First smoke - newbie question