or Connect
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › Trouble getting AMPS to burn
New Posts  All Forums:Forum Nav:

Trouble getting AMPS to burn

post #1 of 9
Thread Starter 

Have a new MES 40" Gen1 electric. 20 years prior experience with an electric bullet, doing pork shoulders and turkeys. The new MES is basically working, did a small batch of brats. As we know the wood box is tiny, so I got the AMPS (Pellet) which so many of you swear by. Testing without meat, w/ oak pellets that came with it. Lights with a torch, 10 minutes flaming, almost an inch of the row has lit. Put it in the MES, the AMPS goes out. Removed the loader tray and the MES chip tray to increase air flow, top vent wide open, plenty of smoke when I first put the AMPS in, but after 15 min almost no visible smoke is escaping. Ambient conditions 45 degrees, not rainy, good breeze, in an open garage near the door. From previous experience I'm expecting a visible cloud of smoke coming out, and not seeing it. So is the holy-grail TBS nearly invisible? Any experienced advice appreciated. Thanks! RF

post #2 of 9

are you blowing on the end of the lit pellets to get a good glowing cherry ? ....... That seems to help with mine ...... microwave the pellets for a couple minutes then load the AMSPS and put it in the smoker while it is heating and for up to an hour before lighting ....... this seems to help ensure  that the pellets are dry and will burn well .

 

 I have not had mine fail yet ............ I've used it 5 times ............. sometimes it takes a while to see good smoke coming from the smoker 

post #3 of 9
Thread Starter 

Thanks voodoo, I'll try drying the pellets first. As a woodworker I know that microwaving or pre-baking can get quite a bit of moisture to come out.

post #4 of 9
Thread Starter 

SUCCESS. Dried my AMPS pellets in the microwave, 2-3 times for a minute, and they burn great. Taking them out of the microwave you can see the water vapor coming off, or collecting on the jar sides. Also left the tray full in the MES for the 45 minutes it took to heat the box up.  Lit the tray with a full size propane torch and let it burn til maybe an inch of the row was glowing, then it burned just fine for about 10 hours. Thanks guys!

post #5 of 9
I have the MES 30 and the amnps.
My problem with the amnps is it never turns the corner.
It will burn a complete row then go out.
I will light the other side and it burns but doesnt make the bend and the middle row never gets lit. By that time im usually tired of playing with it and leave it go.
post #6 of 9
Quote:
Originally Posted by voodoochile View Post
 

are you blowing on the end of the lit pellets to get a good glowing cherry ? ....... That seems to help with mine ...... microwave the pellets for a couple minutes then load the AMSPS and put it in the smoker while it is heating and for up to an hour before lighting ....... this seems to help ensure  that the pellets are dry and will burn well .

 

 I have not had mine fail yet ............ I've used it 5 times ............. sometimes it takes a while to see good smoke coming from the smoker 

Yup this also does the trick for me, now storage can be a future factor also.  I store mine in old milk jugs to prevent moisture from getting in, the bags that the pellets come in seem to have small holes every time I receive them.  Nobodies fault I think it's just the weight placed on the boxes pushing a sharp shard of the pellet through the bag every once in a while.

post #7 of 9
I put my pellets in a wide mouth plastic jar.

RG
post #8 of 9
Thread Starter 

As a woodworker I've learned about moisture with "biscuits", little flat football shaped things used kind of like dowels. If the moisture content gets too high they fit too tight, so I microwave or bake them when I need them dryer. They come in the same kind of ziplock bags the pellets do, and small holes are bound to happen. I keep the biscuits in plastic jars too because they're handy, but a used peanut butter jar or candy jar doesn't seal 100%. Over several months they'll take on water even in a jar. I know they've become damp because if I microwave them again I see plenty of water vapor coming off. So if you need your pellets dry to burn well, I wouldn't trust a plastic jar for 6 months time.

 

Microwave or heated oven both work, whichever's more convenient for you.

RF

post #9 of 9

I put my dust or pellets in jugs like this, as soon as I get them, and never had to nuke any of them.

The only time I have any trouble is with 100% Cherry Pellets.

I almost always use Hickory, but if I must use Cherry, I mix it with Hickory.

 

Bear

 

DSC01239.JPG

 

 

 


Edited by Bearcarver - 1/22/14 at 2:08pm
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Electric Smokers
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › Trouble getting AMPS to burn