post #1 of 1
Thread Starter 

I have the 40" MES with the window.  I was about 4 hours into a Boston Butt pulled pork smoke when I went out to feed in some more wood.  Curiously, I saw no smoke so I looked at the temperature and it was down to 150!  The red light was on but no joy on the element.

GREAT! says I.  I go in the house and turn on the oven, transfer the butt into it and then go back out the the one year old smoker.  I pulled off the lower plate on the back to discover the obvious signs of a 'blow out'.  White splatter on the rubber insulation on the door and melted pieces of metal around the end of the element.  

 

Luckily, the connection blew out above the slip on connector so I pulled off what was left of the connector on the end of the element, sanded it to a bright finish.  Then I carefully removed the remains of the rest of the connector from the wire, cleaned the wires as best I could, and crimped on a new slip-on connector.  Put everything back together and all is good in SMOKEVILLE.

 

From what I've read here, this is a quite common occurrence with MES.  I couldn't see any obvious cause for the failure.  Nothing was touching metal.  The connector was tightly fitted onto the element (at least after it blew up!), the crimped on part was tight to the wire.  

 

I guess I'll just wait and see if it happens again.  Does anyone else know what this happens to so many?

 

ps: I'm glad this didn't happen with my andouille sausage because there's no chance of doing that in the oven!