or Connect
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › New Gen 1 MES 40 won't get hot enough
New Posts  All Forums:Forum Nav:

New Gen 1 MES 40 won't get hot enough

post #1 of 6
Thread Starter 

Just got my early Christmas present.  Seasoned it the other day.  The MES and the Maverick both read around 275 give or take 5 or 6 degrees.

 

However, today I put in a turkey.  It was really cold when I got started, but the afternoon temp in Omaha was around 40-45.  The MES is turned up all the way to 275, but the Mav only reads 212.  IT after 7 hours is 149.  I can't seem to get the temp high enough.

 

HELP!  I need help or a good therapist.

 

Any ideas?

post #2 of 6

Are you using an extension cord?

Is it windy?  Wind is much harder on an MES than cold.

 

The temps of your smoker probes could have been close to the cold bird, but the 149* IT in 7 hours worries me.

 

Bear

post #3 of 6
Thread Starter 

Yes, I'm using an extension cord.  What about the ext cord?

No wind to speak of.  The Mav probe is near the bird on the same rack.  I'm worried about 149, too.  Is there a fix or do I need to call Masterbuilt on Monday.  THis really pi$$es me off.  It shouldn't be this far off.

post #4 of 6
Quote:
Originally Posted by mfreel View Post
 

Yes, I'm using an extension cord.  What about the ext cord?

No wind to speak of.  The Mav probe is near the bird on the same rack.  I'm worried about 149, too.  Is there a fix or do I need to call Masterbuilt on Monday.  THis really pi$$es me off.  It shouldn't be this far off.

 

I'm not an electrician, but I would imagine a cord could make it not come up to full power, but that's just a guess, because the owner's manual says NO EXT CORD. How heavy is your cord?

You could call them, but I would want to find out the problem first. There are many things, such as---Do you have a grill completely blocked with meat and/or foil pans, blocking air flow.

 

 

Bear

post #5 of 6
Thread Starter 

Bear, let me say that you've been a HUGE help on this forum.  There are a lot of good people here!

 

I may have found my problem.  I neglected to add that I put a sheet of alum foil on the rack below the bird.  I may have made it a little too big.  It was pretty much the size of the rack.  I took it out and the temp jumped to 240.  I've been backing it off.  IT has risen to 161 in less than an hour.

 

I can't believe that the alum foil would have prevented the heat from getting to the top half of the MES, but I guess it did. 

 

Hope it's not dry now.

post #6 of 6
Quote:
Originally Posted by mfreel View Post
 

Bear, let me say that you've been a HUGE help on this forum.  There are a lot of good people here!

 

I may have found my problem.  I neglected to add that I put a sheet of alum foil on the rack below the bird.  I may have made it a little too big.  It was pretty much the size of the rack.  I took it out and the temp jumped to 240.  I've been backing it off.  IT has risen to 161 in less than an hour.

 

I can't believe that the alum foil would have prevented the heat from getting to the top half of the MES, but I guess it did. 

 

Hope it's not dry now.

 

------It happened to me when I had two Hams in foil pans on the second shelf. The pans were about 9" X 11". The heat was trapped below that shelf, so the element was cycling with the heat that was under the foil pans, and not getting to the Hams.

 

Bear

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Electric Smokers
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › New Gen 1 MES 40 won't get hot enough