or Connect
SmokingMeatForums.com › Forums › Announcements › Roll Call › New Smoker, need help with my new MES 30
New Posts  All Forums:Forum Nav:

New Smoker, need help with my new MES 30

post #1 of 6
Thread Starter 

Hello all, I picked up an MES 30 last week and tore into it on Saturday.  I noticed on the bottom of the unit there's a small electrical box and there was only 1 rivet holding the lid on the box.  When I looked inside the box, there's one black wire that isn't connected anywhere and doesn't have a clip for connecting it, just bare wires.  Is that normal or should it be connected??  There's a post where it looks like it should be connected but was possibly overlooked and shipped out as is??  I tried to fire it up to get it seasoned as the instructions outline and it kept tripping my breaker for my outside plugs, without extension cord.  Called the Masterbuilt  number and after 55 minutes of holding and finally talking to someone, she couldn't tell me if it needed to be connected or not.  They want to replace just the outer shell  and wiring, rather than the entire unit....no thanks, I'll figure it out.  Any help would be greatly appreciated because I really want to get this thing smoking!

 

Happy Thanksgiving, everyone!

 

One more thing, I look forward to enjoying this Forum and learning more from everyone.  Just a little about me, I live in SW Missouri, south of Joplin and work in NW Arkansas.  Love grilling on my Weber but wanted to get into smoking meat and the Weber just didn't seem like the way to go, great for grilling though!  As a new smoker I'm anxious to work up to a rack a day habit!!  Also a Harley rider, if there's any others out there that live close by, give me a shout and let's ride!

 

Take care,

 

Tony

post #2 of 6

Welcome to the SMF Family...Sounds like it is one of the heating element wires. This thread should be helpful...JJ

 

http://www.smokingmeatforums.com/t/115314/mes-30-wire-repair-with-r-view

post #3 of 6
Thread Starter 

Thanks JJ.  I checked that out and it doesn't look like the same as mine.  Here's a pic that I found on the internet that's very, very similar to my unit.  I circled the wire I'm talking about in red, except mine doesn't have the clip on the end of it, just bare wires.  Thanks

 

 

post #4 of 6

That one I am not familiar with. Some one should be by to help you...JJ

post #5 of 6

Hi Tony and welcome!  I live in NE Okla. not too far from your neck of the woods.  My wife and I like to spend a couple nights at the Downstream a few times a year...Glad you joined our group!  You'll find these forums are a great place to share ideas on smoking, grilling, etc.  There are lots of friendly folks here who genuinely enjoy helping one another.  Looking forward to your input, and just ask when you need something...someone here will surely have the answer.  

 

I can't help with your electrical troubles...I'm unfamiliar with that rig.  You might post this question over in the electric smokers forum.  I'll bet there are some guys over there who can help you solve it.

 

Red

post #6 of 6

texas.gifHello and welcome from East Texas. This is a great site, lots of information and great people that are willing to throw in their two cents worth on about anything  ........ Sorry, RF smoker

 

Gary

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Roll Call
SmokingMeatForums.com › Forums › Announcements › Roll Call › New Smoker, need help with my new MES 30