or Connect
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › MES 40 replace element but now temp and time contrls do not work.
New Posts  All Forums:Forum Nav:

MES 40 replace element but now temp and time contrls do not work.

post #1 of 3
Thread Starter 

I have a MES 40 I purchased two years ago from SAMS.   So far I have replaced the Temp probe, the chip loader and larger chip tray.   On the last smoke doing pork butts I put them on at 10:00pm and when I woke up the next morning the digital readout showed everything still working but upon opening the unit I find not heat inside.  I find the heading element lead was fried on one side of the element.  

 

Masterbuilt sent me a new element.  I put it back on but now I find I can not adjust either temp or Time.   Can anyone give me direction. ?  

 

Thanks in advance

post #2 of 3

Hi Patron

I don't have an MES, but it almost sound to me like a sensor lead or some other wire may have come loose while you were working on it.  Sometimes when there's a problem in the circuit it can cause an electrical surge in the system, you may want to go through and look for any burned wires anywhere.  If it where me I would look for anything that was obvious, burned or loose, then I would call their customer service and see if they have any ideas.

 

Good luck, let us know how you make out.

post #3 of 3
Thread Starter 

Thanks for your help!

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Electric Smokers
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › MES 40 replace element but now temp and time contrls do not work.