or Connect
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › MES40 Repair Help - Cold Element, Toasted Wiring
New Posts  All Forums:Forum Nav:

MES40 Repair Help - Cold Element, Toasted Wiring

post #1 of 3
Thread Starter 

I've had a small love affair with my MES40 over the last year, need some help to rekindle the fire (pun intended).

 

Was in the middle of a smoke and the box temp dropped to ambient.  Luckily, I was cold smoking a couple of hams and it was 90F outside.

 

Element was cold.  Control box was acting normal.  The red "heating" light was on, trying to get up to my 130 set temp.  Hmmm...

 

Found some great info on MES40 troubleshooting here, thanks guys.  Opened the inspection panel on the back and found a toasted wire to the element.  (I guess this is good news, at least it wasn't the relay.)

 

Can anyone give me some help on how to reconnect this?  I'm thinking of cutting off the damaged connector and direct soldering the wire to the element, but there's gotta be a better way.  The prong on the element is strange.  I've never seen a connector quite like this.

 

 

 

 

 

Thanks,

- Nick

post #2 of 3
Directly soldering it should work
post #3 of 3

Mine did the same thing!

I went to the auto parts store and got some Stainless Steel Connectors, and crimped them on

Still working fine

 

It's truly sad that a manufacturer can't put a set of $.50 Stainless Steel Terminal Ends on their smoker, especially if the issue is a known issue!!!

No Creosote! A-Maze-N Smokers

Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Electric Smokers
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › MES40 Repair Help - Cold Element, Toasted Wiring