or Connect
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Charcoal Smokers › Problems controlling temp with DigiQ
New Posts  All Forums:Forum Nav:

Problems controlling temp with DigiQ

post #1 of 3
Thread Starter 
So I am open to any suggestions. I have loved my digiQ from the very start! It has literally saved me Hours upon hours of watching the WSM because I could never get it to stay at a constant temp without it. Today I fired up the smoker with my normal routine. I circle the fire ring with coals and wood chunks, leaving a separation in the ring. I put 15 hot coals on one side(which then usually follows around the ring), and I was up to my 240 set temp in no time flat! Temp just stayed right at 240. I let the meat rest on the counter for 45 minutes or so before I put it on the smoker, but it was still cold. This in turn lowers the temp of the pit, so the fan kicks in. I let it go figuring I would come back in an hr or so and it will have settled in at 240 like it always seems to do. The temp spiked slightly up to about 260 when I first checked it. It has now crept up to 290. It had actually risen to 280 without ever opening the lid! The WSM is sitting in direct sunlight, and the temp outside is right at 90 degrees. Could this be due to the fact that the temperature was a fair amount cooler when I light the fire, and now it is sitting in the direct hot sun? My thoughts is it probably takes very little fuel to keep the smoker at 240 when the ambient temperature is 90, and I may have got to many hot coals going when I put the meat on. Is there a good way of bringing the heat back down on a WSM. I have never really had to do this since I have used the digiQ. I am not worried about the meat, just thinking about how to prevent this in future burns. Any advice is appreciated!
post #2 of 3

Check for air leaks.....   close off the air inlet until the temp drops.....   remove some lit coals........       Dave

post #3 of 3

Air leaks does sound like the likely culprit.  Also if there was any breeze and it is hitting the guru fan inlet at the right angle the breeze alone can stoke the coals up.  Did you try closing the guru fan damper to about 25% open?  That would still let in air and the fan can still increase the flow.  I usually close my Guru damper down to 25% for the first hour or so and it usually keeps the WSM quite happy at 225* without any overshoot.

 

Also what type of charcoal did you use and how big were the wood chunks?  Lump burns hotter than brickette and big chunks of wood love to "flame on" and increase temps also.  Could be a combination of the above.

 

You might also check the calibration of the temp probes.  Guru products can be re-calibrated, and it's not unheard of for probes to go bad.  The check is easy and the re-calibration is in the manual (online at the guru site if you don't still have yours).

 

I would post a link but I have no idea if they are a sponsor and folks seem awful touchy about off site links as of late.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Charcoal Smokers
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Charcoal Smokers › Problems controlling temp with DigiQ