or Connect
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › Smoke issues with MES40
New Posts  All Forums:Forum Nav:

Smoke issues with MES40

post #1 of 10
Thread Starter 
I have a MES 40 and the Amazn tray. I have been using hickory pellets. It seems no matter what I try, the pellets don't stay burning. I have held the blow torch on the pellets for 5 minutes to ensure the pellets were burning. I opened the top vent completely and opened the feeder tray. When I close the door, I get about 10 minutes of smoke and then it goes out. Is there something I am missing?
I want to smoke a brisket tomorrow.

Thanks


Sent from my iPad using Tapatalk HD
post #2 of 10

Where did you put your AMNPS?

I removed my water tray and placed it over the whole and it works just fine!

post #3 of 10
Do you have the new gen 2 with the right side exhaust vent? If so the air flow is so restricted its hard to keep the amazn trays lit. I dremelled mine out to get more flow and it also helped the temp stay closer to set temp without overshooting so much.
post #4 of 10
Thread Starter 
I have the gen1 with the exhaust on the top.
I don't understand the post about removing the water tray? I thought that the water tray was required.


Sent from my iPad using Tapatalk HD
post #5 of 10

Remove the chip burner. Place Amnps in bottom left. Pull chip loader out a inch or 2.....Make sure you have dry pellets. Microwave them a Min. to make sure. Make sure tha AMNPS is gooing real good. Blow on it a few times. Take 10 min or longer to get it going real good. It should have a cherry like a cigar when it is ready.

Happy smoken.

David

post #6 of 10
Quote:
Originally Posted by smokinfam View Post

I have the gen1 with the exhaust on the top.
I don't understand the post about removing the water tray? I thought that the water tray was required.


Sent from my iPad using Tapatalk HD

Water tray is not required. It helps to hold the heat. In mine I filled it with sand and wrapped it in foil. It is used as a heat sink that way. Some will tell you you have to have water. If they want water then water it is. Ask 10 smokers a question and you will get 11 answers.

Happy smoken.

David

post #7 of 10
Quote:
Originally Posted by smokinfam View Post

I have the gen1 with the exhaust on the top.
I don't understand the post about removing the water tray? I thought that the water tray was required.


Sent from my iPad using Tapatalk HD

Johnnytex is talking about the gen2 style water pan. On yours there is a set of rails under the water pan. Under the pan on the rails is a good spot as the water pan protects the amazn from drippings and allows plenty of air. The gen1 has good flow so, like mule says, just take the time to get it going good and hot, open the vent all the way, be sure pellets are dry, and smoke it up!Dr
post #8 of 10

Which pellets are you using? Seems not long ago I heard people having problens lighting straight cherry pellets. Just a thought.

 

Make sure and put something over the tray, juices dripping really mess with the pellets also.

 

I preheat my MES before I add the meat, I leave my aux. smoke gen on the rack while heating, I live in south Louisiana we have humidity. The tray is hot when I light the pellets but I find it drys out the pellets some and helps the continued burn.

 

And don't worry nearly everyone has a problem initially, its just a learning curse.

 

I wish you luck, and hope you have a good smoke!

post #9 of 10

Smokinfam , hello. I feel your pain , as I wrestled with mine a couple of days then the light came on and it sunk in...icon_idea.gifcool.gif. Just slow down and . . .

post #10 of 10

I put the AMNPS filled with pellets and unlit on top of the chip tray assembly while the the MES is heating up to temp. This seems to dry out the pellets so that they burn quite well  when lit a little later just before I put the meat in the MES. I place the lit MES on the lower left rails during the smoke. Just another of many tips you will find on getting the AMNPS to work well. 

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Electric Smokers
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › Smoke issues with MES40