or Connect
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › Chips not maintaining a smoke
New Posts  All Forums:Forum Nav:

Chips not maintaining a smoke

post #1 of 6
Thread Starter 

Hello,

 

 

     I have a smoke hollow electric smoker. The problem I am having is the chips are no longer maintaining  a good smoke. They start, but then stop. Last weekend I did an 8 hr smoke and the chips were hardly burned up when complete. When I first used the smoker I was refilling the chip tray every 3-4 hrs. I also have noticed a reduction in smoke flavor in the meat. 

 

Any suggestions on what might be wrong? The smoker could use a good cleaning as there is alot of build up on the bottom. No vents in the bottom aside from where the grease trap hangs so I didn't think this would be the source of the problem. The electric element has no problem holding temperature. 

post #2 of 6

Have you changed your chips? Are you soaking them? If so, some could be getting over soaked. Another problem is that your unit is holding temp so well that the element isn't kicking on long enough to create smoke besides when you first start. Try cleaning out the tray as much as possible, even scrubbing it to get rid of anything that's keeping a barrier from the wood chips.

 

For a sure-fire way to solve your problem. Try using http://www.amazenproducts.com/ for your smoke source.

post #3 of 6
Thread Starter 

Yep I change the chips and don't soak them as Smoke Hollow does not recommend that for their models. 

 

I will try a good cleaning on it. Any other suggestions?

post #4 of 6

Honestly my advice would be to get an Amazen Smoker for better smoke for a longer time without fighting with chips

post #5 of 6
Thread Starter 

Thanks for the suggestion. 

 

Any other suggestions out there specific to my Smoke Hollow electric smoker?

post #6 of 6

I don't have your smoker....but try wood chunks instead of the chips.  I  do have the tube from Todd....and love it!

 

Kat

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Electric Smokers
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › Chips not maintaining a smoke