or Connect
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › Masterbuilt 40 won't turn on... Help!!
New Posts  All Forums:Forum Nav:

Masterbuilt 40 won't turn on... Help!!

post #1 of 13
Thread Starter 

Hey guys thanks in advance.

 

 

My Masterbuilt 40 was on an extension cord plugged into a power strip and an iron was used in the power strip and my smoker turned off. Now it wont turn on. Also it had to be stored outside and its been a rainy season I'm concerned about mold and I cannot turn it on to kill any mold in case there is any. Any help is greatly appreciated to get my smoker back up and running Thank you!

post #2 of 13

Have you tried it in a different Outlet and with a different Extension Cord? The heating coil in the MES and the Iron most likely tripped the breaker to the Outlet it was plugged into or the the breaker on the power strip...JJ

post #3 of 13
Thread Starter 

I plugged it in directly to another outlet and nothing...

post #4 of 13
Thread Starter 

It's happened before and I switched the breaker which turned it back on....now that doesnt seem to be working..

post #5 of 13

I am not aware of any breaker or fuse in the MES and it does not sound like a power surge hit the Smoker. This may sound silly but did you verify the second outlet works with something else so you can narrow the problem down to just the MES. There is pretty much only the Electronics that could have been affected. If there is power to the outlet, I would contact Masterbuilt to see what they say...JJ

post #6 of 13
Thread Starter 

I will make sure to be as thorough as possible and then take it from there to contact Masterbuilt if needed. Thanks!

post #7 of 13

Have you tried the remote.  I had the control unit go bad on me (it got water in it i think)  and none of the buttons on the smoker itself would work.  However, when I tried the remote I could get it to work properly.  Masterbuilt sent me a new control unit that fixed the problem, but I could still smoke a little while I waited for it to arrive.  Hope you get it fixed.

post #8 of 13
Thread Starter 

Thanks, yeah I tried a bunch of stuff Just got off the phone with Masterbuilt they're sending me a new control unit and heating element. So lesson learned but there will be smoked meat this summer!!! Cheers and Thanks!

post #9 of 13
Thread Starter 

Ok so I got a new heating element and control panel from Masterbuilt. Here's the thing. I put on the new control panel and it still didn't turn on. Do I need to put in th new heating element to get power? I dont have time today to put in the heating element just wanted to see if the thing would turn on. Thanks,

post #10 of 13

Hi I know it has been a couple years that you had this problem but I was wondering if the heating element fixed the problem?  I had a little fire in Mine :) and now it won't power on .  I got a new controler but it didn't work either. 

 

Thanks for your help

post #11 of 13

Firedude212

 

Does the display light up on your control panel?

 

Have you opened the back and inspected the terminal of the heater?

 

 

Walta

post #12 of 13

No the lights do not light up on the control panel

 

I have not yet taken the back cover off yet I had lower model Masterbuilt before this replacement one and had the burner go out several time however the unit would still turn on just not heat up. 

 

I am going to take it apart later today and see what I can tell 

 

Thanks Justin

post #13 of 13

Firedude212

 

Is your outlet GFCI protected?

 

Please plug something else in your outlet and see if it is working.

 

Walta

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Electric Smokers
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › Masterbuilt 40 won't turn on... Help!!