or Connect
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Pellet Smokers  › YS640 with a problem...HELP????
New Posts  All Forums:Forum Nav:

YS640 with a problem...HELP????

post #1 of 14
Thread Starter 

I bought the YS640 on Thursday got it home all set up but didn't get the chance to do a bun in until Saturday.

 
I turn it on the power light comes on (Blue) and I hear the fan going, I push the start button.......NOTHING happens, blank display. The only thing that's on is the light and fan. I turn it off and wait 3 minutes per the instructions and try it again, same thing...NOTHING! I'm bummed!!!!!! I waited 15 minutes maybe something would happen, NOPE! I have called the dealer but it's Saturday and they are gone for the weekend.
 
I want to open the side of the hopper and see if there's anything unplugged or something but I don't want to void my warranty either. By trade I'm an electronic technician and I'm very familiar with electronic.
I've emailed yoder and the dealer but with it being Saturday I'm sure I'm SOL until Monday.
 
Michael
post #2 of 14

Did you try Manually Priming it?  Basically wondering if the Auger works at all here.  Once you hit the start button your readout should start flashing 3 bars in a rising mode then 350.

post #3 of 14
Thread Starter 

That was the thing ONLY the "blue" light was on and I could hear the fan but that was it no display.  And yes I did manually primed it, it was like there wasn't any power to the control board or something.

This morning I was going to open it up but I thought I would give it another try.....And it worked, U26 came up on the display, I pushed the start button and pellets started to fall! Something is intermittence though, so I'm still going to open it up and take a look at all of the contacts, grounds and all of the plugs. Something isn't right, it should work every time. So for now I'm going to burn it for an hour at 350 degrees and then put bacon all over the grills and season the metal a little bit. BLT's for lunch!

Once it hit the 350 degree mark it only held it for a couple of minutes and then dropped down to 332 degrees and held that with the center dashes on the display ---, like it was holding 350 but it wasn't.I waited another 20 minutes and the temp came back up. The cooking hood has not been touched either it's been closed the whole time.

Thanks guys for your help, Michael

post #4 of 14

Sounds good, hope you had a GREAT first meal from it today.

post #5 of 14
Thread Starter 

Thanks it was very good smoked bacon.

 

Michael

post #6 of 14

Right on, can't say that I've had any BAD meals come from mine.  Just some that were better than others.

post #7 of 14

Keep us informed as to what the problem was and if you got it solved.

post #8 of 14

I've got a brand new one also with only three smokes behind me now.  I thought that the temp swings high and low from the set temp I think have been rather wide.  The first smoke I had it set for 335 and it actually went to 386 before it turned around.  I have fooled around with the temp setting less on the last smoke and it did much better.  I put a mavrick 732 on the top shelf on the last smoke and it was sometimes 10-15 degrees different from the set temp.  After a while it finally leveled out and held closer.  I think that there is a learning curve and I am trying to zero in on it.  I wish that it had done better but I haven't given up on it by a long shot.

post #9 of 14

The top rack should be a different temp....I think.  The computer temp probe is at the lower rack level...would be hard to have the upper rack be the same temp as the lower..at least that is how it works on my offset.

post #10 of 14

with the fan circulating the air throughout the smoker the temps are closer than you would think but you are correct the top shelf is slightly hotter.  With my first two smokes my wife complained that she couldn't taste much smoke.  On my third smoke I did a tri tip and used Tods 18 inch tube.  It did the trick and in a couple of hours did a beautiful job as far as smoke taste goes.

post #11 of 14
Thread Starter 
Quote:
Originally Posted by Show me Smoke View Post

Keep us informed as to what the problem was and if you got it solved.

Long story short my Yoder is fixed.  The problems was the control board, Yoder has a problem with these boards I'm guessing in new smokers or maybe I'm just the lucky one??
 
They sent me out a new board and I had that same problem.  I emailed them with all of my contact info along with work number, home too, called them and left a message.....No call,email anything for 5 days, then another board showed up.  I would have thought that I would get some kind of contact from them to tell me what's going on, instead of they just send out another board and leaving me hanging there!  I read all the time how great the customer service is with Yoder, but I didn't get great customer service in my eyes, kind of disappointed.

 

Michael


Edited by humdinger4u - 5/2/13 at 6:01am
post #12 of 14

I called and left a message for don the owner as someone told me to do and I have had no call either.  I am still leaning that way and I found a used one locally that I have some interest in if they lower the price a few hundred as I'd have to rent a truck to drive 2 hrs from CT to Long Island to pick it up.  Are the warrenty's transferable on these units?  I know that Ron from Rec Tec called me the day I first posted on a board and that Bob at MAK has been emailing me big time.  I have no concerns if I end up with either of those two that they will be there for me.  

post #13 of 14
Thread Starter 
Quote:
Originally Posted by ctsooner View Post

I called and left a message for don the owner as someone told me to do and I have had no call either.  I am still leaning that way and I found a used one locally that I have some interest in if they lower the price a few hundred as I'd have to rent a truck to drive 2 hrs from CT to Long Island to pick it up.  Are the warrenty's transferable on these units?  I know that Ron from Rec Tec called me the day I first posted on a board and that Bob at MAK has been emailing me big time.  I have no concerns if I end up with either of those two that they will be there for me.  

Yeah that's how it worked for me too, I don't get it.  Others made it sound like it so easy to get a hold of some one but I never found that to be the case. 

 

Good luck!!

 

Michael

post #14 of 14

I tried again and didn't leave a message.  Also, a store I went to today have been trying to get a call back and they haven't called. He is hoping to maybe pick them up, but I'm now concerned if even a prospective dealer can't get a call back.  Very strange as the Yoder  fans LOVE their units.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Pellet Smokers
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Pellet Smokers  › YS640 with a problem...HELP????