SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › MES30 - Won't turn on. Frozen?
New Posts  All Forums:Forum Nav:

MES30 - Won't turn on. Frozen? - Page 2

post #21 of 26
Thread Starter 

Will do!

post #22 of 26
Thread Starter 

For those interested, here is my service experience with Masterbuilt:

 

 

 

 

Quote:

Hello,

 

Thank you for contacting Masterbuilt, and we apologize about the problem which you are experiencing with our product. What you are experiencing indicates a problem within the wiring of the body of the smoker and we would have to replace the control panel and body. Do you still have a proof of purchase that you can provide me?

 

Regards,

 

XXXXXX

 

Masterbuilt Customer Service

 

 

I told her I had the receipt and sent it.  She wrote back:

 

 

 

 

Quote:

You're very welcome. We will have to replace the control panel and body of your smoker. To begin this warranty process, please mail me the cord and the data plate off of the back of your smoker (you can cut the cord off and the data plate is pop riveted on and can be removed with a flat head screwdriver). You will send these parts to:

 
 
XXXXXXX
 
Please save the grates, water bowl, and door because they will have to be transferred into the new unit and let me know if you have any further questions. If you would like to email me with the tracking number to your shipment then I can go ahead and process your warranty. If you have any further questions, please let me know.
 

 

Regards,

 

XXXXXXX

 

As far as I'm concerned, that's great service.

post #23 of 26

cts, evening....  Use a hair dryer inside the smoker on both of the heat sensors....  the display should turn on .....   set time and temp... keep heat on the sensors until the element can warm the inside of the smoker....  that's a common problem with MES units....    Dave

post #24 of 26

When mine did that I put the tea kettle on the stove till it whistled then put it inside the smoker till it almost cooled to the touch then set it on top for a few. seems like it was just to cold for the temp sensors to register and it would not let the unit run , kinda like a failsafe function.

post #25 of 26

-9 here this morning and my MES wouldn't turn on.  Hair dryer to the control board did the trick!

 

Thanks guys!!!

post #26 of 26
Quote:
Originally Posted by Chitown Smoker View Post
 

I thought the breaker might be tripped, so I popped it out and in, and then plugged in a power strip which turned on.  Plugged and unplugged the MES a couple more times - one time I unplugged I heard a beep.  Then I plugged it back in and the Heat red light is blinking over and over and clicking.  That's how it is now - I don't know if that means it's trying to heat or if it's going to melt the damn thing.  


The clicking sound is not normal. You should call customer service if they take too long replying to your email. Is your smoker still under warranty?

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Electric Smokers
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › MES30 - Won't turn on. Frozen?