or Connect
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Meat Thermometers › model ET 732 redi check
New Posts  All Forums:Forum Nav:

model ET 732 redi check

post #1 of 18
Thread Starter 

        sitting up my thermometer i got it to register in smoker but with the meat probe in all i see is HHH ANY I IDEAS  need help and i see nothing in the instructions

post #2 of 18
thats usually a bad probe. Call Maverick. They will send you replacements no problem.
post #3 of 18

Mine does the same thing, from time to time. It also does LLL. I found that making sure the probe is really connected tight and then wait a few seconds. If it doesn't register within a few seconds you have to reboot the two thermometers. That always fixes it.

Hope it works for you. If you find out you have a bad probe, let us know.
Thanks for posting,


post #4 of 18

I just went on line and looked at the owners manual. I was too lazy to find mine. Here's what it says:


Page two, right column:




Helpful Hints

If the receiver and / or the transmitter display LLL or HHH instead of the probe temperature, wait

for probe to reach room temperature. If LLL or HHH is still displayed, it is likely the internal probe

wire has shorted out either through moisture or heat damage.



post #5 of 18
Easy to fix they are not shorted! They have got damp. Just put probes ib oven. Leave plastic ends out of coarse. Bake on 350-400 for two hours then try. Has fixed many probes and havent had one yet it wont.

Sent from my DROIDX using Tapatalk 2
post #6 of 18
Thread Starter 

might have been the probe. after i sent this i pushed in and moved it around an within 10 min it came on with a temp

showing temp so far so good hope it keeps up thanks for the help

post #7 of 18
I just tried this trick of putting 4 probes in oven at 350 degrees for 2 hours and the probes now read within specs. Another thing I did is to coat 3-5 inches of the braid next to the probe with Liquid Tape. I used the bottle with a brush applicator but you could use the spray as well. According to the Liquid Tape specs it works up to 200 degrees, but I tested it at 400 degrees and it still stayed solid and sealed the braid to avoid further water damaage.
post #8 of 18

Been awhile since I've been here. Glad you found your problem. I have also found that if I get the probes ready and in place, I turn the receiver on first and then the transmitter. I get HHH every time if I don't do it this way.

post #9 of 18

I was getting the "LLL" message on mine, on the barbecue sensor (not the food sensor)..  I restarted both the sending unit and the receiving unit, and that worked -- for about a minute.  The "LLL" reading returned.  Then I took a better look at the sensor, and I realized I hadn't cleaned off any of the carbon in quite a while.  Once I did that, it worked perfectly. 

post #10 of 18

what works good to clean off the carbon on the probe?

post #11 of 18
Spray bleach works good
post #12 of 18

thank you Dockman

post #13 of 18

Right now my food probe is reading 100 degrees too high - have done a cold start, cleaned the probe. Unit is only a 3 months old.  Will try the oven trick next - but I have 13 lbs of pork shoulder smoking - grrrrr.

post #14 of 18

I had this problem with mine as well.  Different probes all had readings that were way off.  I took a Q-tip and cleaned the ports on the transmitter where the probes are inserted and they were very dirty.  I reattached the probes and everything went back to normal.  Checked them in ice water and boiling water and it was within 2°F on both.

post #15 of 18
Originally Posted by bmudd14474 View Post

thats usually a bad probe. Call Maverick. They will send you replacements no problem.
I have the Redi Check by Maverick and never had any problem with it. It does say to only wash the point of probe.
post #16 of 18

Awesome post!


I was in a panic today as my ET-733 was showing LLL for both probes. I am really careful about how I clean them.


Put them in the oven for 2.5 hours at 350 degrees, it worked!!!!!


Now to get them out in the smoker, thanks for sharing!!

post #17 of 18

I too have the "LLL" error on the oven probe. I ordered a new one and received it yesterday, plugged it in and still get the same error. 


I was about to clean the ports with a Q-Tip, yet they're so small that a Q-Tip would never fit. What to do?


I also checked the batteries. In the transmitter, they had some corrosion on them, cleaned the terminals up with vinegar , popped in a fresh set and no difference. The receiver batteries are fine.


What else can I do? Should I still have to pop the new probe into the oven for a couple hours?




EDIT: Just realized that the probe I received was for a different Maverick. Ordered another one, so will wait and see.

Edited by GYnot - 6/20/15 at 11:29am
post #18 of 18

When I turned on my ET-733 a couple of days ago the FOOD probe display was HHH. I checked and the probe wasn't fully plugged in. Plugged it in and problem solved. Of course it's not always that simple.


I've seen LLL or HHH happen a couple of times. To fix them I would shut off both units, unplug and replug in both probes. Both times I had to repeat this twice and it was problem solved. I've also noticed that both probes should be plugged into the transmitter (with the transmitter off) before the receiver is turned on followed by turning on the transmitter.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Meat Thermometers
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Meat Thermometers › model ET 732 redi check