or Connect
New Posts  All Forums:Forum Nav:

Need HELP with a Foodsaver

post #1 of 6
Thread Starter 

I bought a Foodsaver V3020 awhile back and have only used it twice. The first time I bagged 12 bags of pastrami and I had 2 bags that wouldn't vacuum.. I didn't think to much of it. Tonight I was bagging my roast beef and I had 6 bags that wouldn't vacuum. I am using the 8" roll and cut each bag the same length and sealed one end twice. I did everything exactly the same and one bag would vacuum and the next wouldn't then the next would just fine so I don't think it's the machine. It might be me but I tried doing everything exactly the same and even tried different ways with the ones that wouldn't vacuum. I even took the meat out and tried it empty and still no vacuum.

Has anyone ever had this problem? Am I doing something wrong or could I have a defective roll? Oh yea, all the bags came from the same roll.

I'm just kind of frustrated right now because the rolls aren't cheap and I just threw a bunch away.

Any suggestions would be greatly appreciated, Thanks in advance! 



post #2 of 6

I'm not sure about that specific model but on the smaller models you have to let them cool down after half a dozen bags or so.

post #3 of 6
Thread Starter 
Originally Posted by alblancher View Post

I'm not sure about that specific model but on the smaller models you have to let them cool down after half a dozen bags or so.

Thanks for the reply Al, but the problem wasn't with sealing it was with vacuuming. I put in a bag right after the one that didn't vacuum and it vacuumed fine. I don't think it was a heat problem, I have experienced that and when it does the light blinks but that is when sealing not vacuuming. The light never blinked and it was making noise like it was vacuuming but no air was leaving the bag.


post #4 of 6

I got an older model and have had a few run ins with it. I found sometimes the bag is wrinkled or holding the seal open a little bit. Mine also has to wait for a few seconds and when I hear a small click then I can do the vacum and seal, otherwise it trys to seal before vacum. Weird but, like I said its old like me and forgets the sequences sometimes.

post #5 of 6
Thread Starter 

Yea I thought maybe the bag was getting wrinkled or something but I tried a couple of bags that didn't vacuum with nothing in them and they were definitely flat and still wouldn't vacuum.

post #6 of 6

No problems with mine yet. Knock on wood!


The bags do have to be pulled out flat so there are no wrinkles. The sealing area has to be clean.  The bags have to extend into the trough. They do need a rest between sealing bags as covered in the instructions.


Also, you can get better bags and save a bunch of money here:




Check out:




Good luck and good smoking.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Smoking Gadgets and Tools.