or Connect
New Posts  All Forums:Forum Nav:

RIB FAIL

post #1 of 7
Thread Starter 

So I had some guest over this weekend & everyone requested something on the smoker. Wanting to make something everyone was sure to enjoy & not wanting to smoke ALL day & hope it gets done in a timely fashion. I thought how about ribs. Of course might as well throw on some ABTS & been wanting to some pork shots. I recently purchased a new WSM 18.5 had it filled top & bottom so I had to fire up the back up smoker. This is where things went in different directions? Here the pics!

 

feb.JPG

 

Rubbed, rested, & ready!

 

photo 6.JPG

 

Two hours later getting ready to wrap. Here's where I should of noticed? The ones on top have ALOT of pull back & the ones on bottom on the back-up smoker are not even close? I thought the foil would bring them closer together when done, but after 1.5 hours in foil the ones on top where SO done they almost fell apart when I touched them ( too done IMHO )

 

photo 2.JPG

 

I wrapped in foil & kept them warm until the others were done. Here's how they looked. Long story short the ones in the WSM where falling apart, yet they were EVERY ONES favorite? Even my wife said they were my best. I didn't care for them that much? The others were way too tuff. I had to put the other racks back in foil & in the smoker hoping they might braise just a little before we were out of food. Again this is where I should of had a clue!! One hour more in foil with apple juice & STILL tuff!! It took the oven & TWO more hours before they were tender enough? I guessing it must be time to calibrate BOTH smokers! The WSM were OVER done in 3.5 hours & the ones in the back-up smoker took 7.5 hours??

 

Now onto the sides

 

photo 5.JPG

 

ABTS, some with Jalapenos & some with mini bells

 

photo.JPG

 

Pork Shots ( sorry for the blurry pic )  These had just 50/50 rub & turbinado sugar. Again another fail?

 

photo 3.JPG

 

They looked OK but I couldn't seem to get the sugar to break down? It stayed crystallized the whole time? Weird?

 

photo 4.JPG

 

So these where my first pork shots & again everyone said they were good, BUT THEY LIE!!

I couldn't wait to try one & the first thing I thought was how incredibily DRY they were? Tried one more & this time looked at the bottom. They were as close to burnt as you could get? Same with the ABTS? I think everyone was just being nice cause they were not good in anyway!!!  So I don't know if this is another little learning curve with the WSM & if the gage is off? The tops never looked done on any of the shots or turds, but almost burnt on bottom.

 

So that's my rib fail & I will chalk this up to a learning experience & the good news is I'm gonna have to try again this weekend till I figure out whats going on! Either way I still ate the ribs!!

post #2 of 7

Well, a little more information might help.

 

What temp did you have the smoker set to?  Also, the therm on the WSM is typically off, and can be by quite a bit, which is why most everyone on here has a "probe" therm that they test in boiling water for accuracy.  Might be something to look for in the future.

 

I will agree that "fall off the bone" ribs are too done, at least I think so.  Given, they still taste great, but I love to have a little "pull" to get the meat off the bone!  I've found that most people prefer the fall off the bone style, at least my friends and family.

 

I have 0 input on the pork shots as I've never done them!

 

What rub did you use for the ribs?  How long smoked?  What temp?  What was the back up smoker?  How long between rubbing and smoking?

post #3 of 7

Eat the evidence, and all is well!  My first pork shots weren't great either.

 

The thermos on most units are normally not calibrated at the factory, or they can get knocked out of range by shipping.

 

If you have multiple thermometers, simply calibrate them and make sure they are OK.  I have had bad thermos, bad leads, and a bad attitude cased by both.  Test them in boiling water, and in ice cold water.

 

Keep up the good work!

post #4 of 7
Thread Starter 

Yeah I know the stock gage will be off. I have had it & my back-up smoker ( charbroil gourmet offset ) calibrated & know what temp I'm cooking at. I think some how the gages went a little further off ( maybe in each direction with both ) as I had both smokers at 225-250. Using the 2-2-1 method. I havent smoked in probably a month or so. Either way I'll figure I have to try again this weekend & just have to eat that too.

post #5 of 7

The factory gauge on my WSM runs about 50 degrees lower than the top grate temp. Also the bottom rack will run about 15 degrees cooler than the top rack. The outside edges will be hotter than the middle on both racks. There is a learning curve.

post #6 of 7
Thread Starter 

Thanks Al. I did use another gauge on the top rack when I first started with my WSM. It was off by 20 degrees form top grate to what the gauge was reading, but your saying it could be as much as 50? So IF the factory gauge is reading 250 at the top of the lid it could be as much as 300 on the grate & 315 on the bottom? Im actually figuring something like that, I just haven't had the time to test it. Sure would make since to get those ribs on the bottom done in 3.5

post #7 of 7

Terry, I would say, you were easily over 300 to get fall apart ribs in 3.5 hours...That would be just about spot on for a 325* oven...JJ

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Pork