or Connect
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › new PID not working right, big temp swings
New Posts  All Forums:Forum Nav:

new PID not working right, big temp swings

post #1 of 3
Thread Starter 

Got all the components and put together a controller for my electric smoke hollow. PID turns on and activates the SSR starting out. Temps climb up and over target set on pid then eventually fall back down but way below target then way above and so on and so on........ Not using the auto tune, just plugged it in and set my 225 temp(well actually 107 cause i messed up and this unit only does Celcius) but should still be fine i assume. Could it possibly be bad or am i missing something?

post #2 of 3

Provide a picture of the inside of the set up of the controlled unit... Is there a circulating fan to maintain even heat distribution inside the unit??

Wattage of the element.... size of the box.... Is it insulated.... size of the vents...  are they open, closed, partially open...    All of which plays a part in controlling temperatures....  The PID is turning on and off so it is working...

 

Is the heater "over sized" .... too much "heat" will cause the temps to shoot past the set point then fall below, before turning on again...

 

Just my first thoughts...  Dave

post #3 of 3

maybe check your manual, I think you can set the parameters to tighten up them swings

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Electric Smokers
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › new PID not working right, big temp swings