or Connect
SmokingMeatForums.com › Forums › Announcements › Roll Call › First Post (Kind of) - Cabela's Pro 100 issue/problem
New Posts  All Forums:Forum Nav:

First Post (Kind of) - Cabela's Pro 100 issue/problem

post #1 of 15
Thread Starter 

I responded earlier in Pappa Bear's Cabela's Pro 100 post, but this one is my first thread here.  I just got my Cabela's Pro 100 smoker last Saturday, got it out of the box this week and was preparing to season it.  When I turn it on the display says 215.  The burners won't heat up until I set it above 215.  The longer I let it go, the temp on the display drops a little.  I've been playing with it and so far the display has dropped to 188 (in about an hour).  I keep dropping the settings to just a hair higher to keep it heating.  Dropped my meat probe down the exhaust port to verify temps and they are climbing up to 150, so I know it is heating inside.

 

Anyone have any ideas, or does this thing take a ride back to Cabela's in the a.m.?  Then I have to resort to my broken down Bradley to get me two racks of ribs finished...  I was looking forward to using this smoker.  I make tons of summer sausage, pepper sticks and other venison based products throughout the year.

 

Rick

post #2 of 15

icon_cool.gif

First off welcome to SMF there Rick. It sounds to me like that thing needs to take a long ride on a short pier. You'll really like this place for there are a bunch of really good folks here that would just love to help you with just about anything to do with smoking meat. Then if you have any questions you just post them here or yu can try in chat for a faster answer. If you are really new to all of this I would recommend that you look up and take the e-course. It is free and it will also give you the basics on smoking. So with all that said now go and get something to smoke.

 

Welcome To Your New Addiction

post #3 of 15

Not familiar with that type smoker.

Someone will be along soon to help you out

 

   welcome1.gif To SMF

post #4 of 15
Thread Starter 

Thanks guys, any help is welcome.  I had to return my first Bradley to them a few years back as well.  Door wouldn't seal on that one.  This looks like an electrical/controller problem.  It has now stalled out around 185 on the display.

post #5 of 15

smf.gif

post #6 of 15

Welcome to SMF! I'm not familiar with your smoker either.

post #7 of 15

I have a cabelas electric, but without the electronic display (Mine's a dial) - which I replaced with a PID.

So I dont really have the same model as you, but here are my thoughts anyway:

- is it possible that the electronic controller is cycling the element on/off ?

- If not, or if it takes more than 15-20 minutes to get a significant temp rise, then I'd be headed back to cabelas.

 

FYI, The heating element in mine is too small, it cant keep up in cold temps. I intend to replace it.  So if you do end up returning it, I'd also suggest looking at the size of the element in the one you replace it with.

post #8 of 15

btw, the reason I got a PID is explained in this post:

http://www.smokingmeatforums.com/t/76336/temp-control-is-worthless

post #9 of 15

Rick, morning.... If the display says 215 deg and the smoker is cold..... there is a problem in the logic.... I would return it and when you get the replacement, take it out of the box and plug it in there. Take extra therms to check out if all the temps are close enough that you can live with it..... Put it back in the box and head home or get another replacement if you are not happy....

Hope that works for you....

Dave

 

If you are near the main store, have lunch at Hemingway's... Great food at a good price when I was last there....

post #10 of 15

Welcome Rick!

 

Lots of resources, and experiences from around the globe here.

 

Obviously you know how to use the search, read up, and go get 'em! You will be great!! Enjoy!

 

Good luck with the Pro 100, hope the problem is solved quickly.

 

Please let us look over your shoulder by sending photos of your smoker, and your efforts.

post #11 of 15
Thread Starter 

Thanks plj & Dave.  Left it on the deck all night (10 degrees this AM).  Plugged it in and presto: 215 degrees.  It now rests in Cabela's return department.  New one should arrive before Christmas, which is good, I need to make some summer sausage for Chirstmas gifts.  Limping my ribs along in the Bradley and firing up the oven so they will be done by lunch.  I'm on the other end of the state from the main store, but the La Vista store is less than 5-minutes from my house.  biggrin.gif

post #12 of 15
Quote:
Originally Posted by RickWL63 View Post

Thanks plj & Dave.  Left it on the deck all night (10 degrees this AM).  Plugged it in and presto: 215 degrees.  It now rests in Cabela's return department.  New one should arrive before Christmas, which is good, I need to make some summer sausage for Chirstmas gifts.  Limping my ribs along in the Bradley and firing up the oven so they will be done by lunch.  I'm on the other end of the state from the main store, but the La Vista store is less than 5-minutes from my house.  biggrin.gif

That would be "NOT GOOD" for me.... icon_mrgreen.gif

 

 

post #13 of 15
Thread Starter 

Yeah, my wife thinks I have a room there.... My credit card balance reflects that...

 

post #14 of 15

Welcome to SMF glad you can join us.  We are big on Pics and love to help everyone out.  Remember the only question that is dumb is one not asked.  You will not find a friendlier place to talk Que on the web.

 

You are going to fit in just fine.

post #15 of 15

Welcome to the site Rick and glad to have you with us. If I had a Cabelas 5 min from the house I would probably be single by now.icon_eek.gif  I have a BassPro an hour away and a Cabelas about an hour and a quarter away. That's close enough. LOL!

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Roll Call
SmokingMeatForums.com › Forums › Announcements › Roll Call › First Post (Kind of) - Cabela's Pro 100 issue/problem