New Posts  All Forums:Forum Nav:

MES Temp question

post #1 of 8
Thread Starter 

Alright I am doing some jerky in my MES 30. I set the temp at 145 but the meat probe is reading at 120. Do i trust the set temp or meat probe temp? Its been in there around 2 hours.

post #2 of 8

I only trust my probe thermometers. I dont have an MES but it does not seem that many of the smokers temps are very accurate.

post #3 of 8
I love my mes but they're famous for being off on temp. I would try the boiling water test on your temp probe and trust that over the mes thermometer. It could just be the placement of the meat since temps vary inside by location. Close proximity to the heat element will be hotter etc...
post #4 of 8
Quote:
Originally Posted by teeznuts View Post

I love my mes but they're famous for being off on temp. I would try the boiling water test on your temp probe and trust that over the mes thermometer. It could just be the placement of the meat since temps vary inside by location. Close proximity to the heat element will be hotter etc...


Teeznuts  is right i  got a MES 30' and the set temp is out by 12%

 

post #5 of 8

Never seen a factory therm that was correct.

post #6 of 8

And.....

Every rack will have a different temp

The right rear corner is a "Hot Spot", all the way from the bottom to the top

My MES is 15° - 20° off, depending on which rack I'm using.

 

 

Todd

No Creosote! A-Maze-N Smokers

Reply
post #7 of 8

I only trust the digital temp probe I put in the meat, and only when I know it's accurate because I tested it.

 

I think a lot of the differences we get in all of out various therms has a lot to do with the air flow in the smokers.

Our remote Mavericks and others are quicker to change when the heat goes up and down in the smoker, but I'll tell you all something I discovered last night that confirms my thoughts on air flow throughout the inside of an MES 40.

 

At the end of about a 5 hours smoke, I had all of the meat in a covered foil pan on the second shelf.

During the smoke, my temps were reading quite a bit differently, due to where they were, and due to the air currents I'm talking about.

My smoke was done about 90 minutes before Supper time, so I just left both of my ET-732 probes hanging on the second shelf, in the air. The MES meat probe was still in it's holder.

I turned the heat down from 225˚ to 160˚.

By the time the temp got down to 190˚, they were all reading exactly the same---ALL 4 THERMS !!!!

They stayed within 1 degree of each other all the way down to 160˚.

I changed the setting to 140˚, and they stayed he same all the way to 140˚, before I killed the power.

 

It is my opinion that all 4 of my therms are very accurate, and the differing temps I get during my smokes, sometimes up to 30˚, is not a problem with the MES accuracy, or the Maverick. It is due to the air currents within the MES itself, because on the way down they all got together & stayed the same, because no air currents were being created by the heating element, and it wasn't windy out.

 

Just my observations & opinion,

Bear


Edited by Bearcarver - 9/27/11 at 9:55am
post #8 of 8
Thread Starter 

Alright I ran my other digital thermometer and it ran about 10 degree hotter then the meat probe

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Electric Smokers