SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › My 30" MES died...suggestions?
New Posts  All Forums:Forum Nav:

My 30" MES died...suggestions?

post #1 of 5
Thread Starter 

I have a 20070106 that have had for about 3 years now.  Absolutely love it!   

 

The other day, it quit smoking.  th_crybaby2.gif The red heat inidicator light was on, the rest of the panel also looked normal...but no heat.

 

Would the likely problem be the element it out?  Or a problem with the controller? (Unplugged to hopefully "reset", but did not resolve.)  

 

I have not contacted Masterbuilt yet as I figured I would ask here first.  Any suggestions to check before I call?  Can the element be tested with a multimeter?

 

Thanks!

-Dex

post #2 of 5

My guess would be the female spade terminals that connect to the heating element have disintegrated . If you do whatever it takes to get into the little box containing the wires for the element you might find that's the case . Somewhere on the forum there is a nice post with a lot of photos detailing the repair . Mine died about 4 months after I got it and the female spades were gone . I just went to the hardware and got appliance terminals , crimped and then soldered them to the old wires and that was 4 or 5 years ago and it's been working ever since . I think the repair post they replaced some of the wiring with the high temp appliance wire but I didn't do that . I just think the stock connectors are probably really crappy Chinese metal and then additionally maybe they get some salty air in the shipping process , they literally end up not being able to take the heat and just turn to dust . My unit had the back panel screwed on but I know some are riveted . It's an easy fix but kind of a PIA to get to the spot to perform the work . Good luck . Or use this as an excuse to get the 40" model . If you have used yours even half as much as I've used mine I would think that it's earned it's keep anyway.

post #3 of 5
Thread Starter 

Thx for the response.  I will tear into rear panel and check the terminals tonight.

post #4 of 5

jsd gave good info.

 

Note: If you want to use this as an excuse to get the MES 40, do it before you fix this one. You can always fix it after you get the MES 40.   biggrin.gif

 

 

Bear

post #5 of 5
Thread Starter 

Looks like it was indeed a corroded terminal.  thx for the tip!

 

2011-06-07_17-01-04_475.jpg

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Electric Smokers
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › My 30" MES died...suggestions?