SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › MES 40 goes dead intermittantly - Bad controller or overheat sensor?
New Posts  All Forums:Forum Nav:

MES 40 goes dead intermittantly - Bad controller or overheat sensor?

post #1 of 5
Thread Starter 

Hi,

 

While using my MES 40 (model 20070710) this past weekend to smoke some ribs, it went temporarily dead after about 3 hours of smoking. The controller display went completely dead along with the heating element and the inside light. I confirmed that there was power at the outlet. I unplugged the power cord and then plugged it back in after 1 minute and the MES was still dead. I unplugged the power cord and then plugged it back in 1 hour later and the MES powered up again as normal. After about 1 more hour of smoking, the MES went dead again. It did not power up after a quick unplugging but it did power up again after another 1/2 hour or so of being unplugged. I called Masterbuilt support about getting a replacement controller. The support person said that it did not sound like a defective controller and that the MES's overheat sensor might be causing the problem. She said that the sensor is not readily accessable and that the whole smoker box would need to be replaced. I bought the MES from Cabelas' last Oct 2010, but unfortunately I can not find my receipt, which is required to get a replacement box, so I may be SOL with any warranty help.

 

My question is this. Has anyone else had a similar problem (intermittant and random dead unit) that was solved by replacing the controller? I thought I would ask as I would gladly pay for a replacement controller myself if there was a good chance that it would solve my problem.

post #2 of 5

I have not had that issue with mine but it is alittle over a month old now so hope it dont have any of the problums you speak of at all.


 

post #3 of 5

Have you tried removing the control box from the smoker and then plugging it back in to make sure it is connected securely?

post #4 of 5
Thread Starter 

Quote:

Have you tried removing the control box from the smoker and then plugging it back in to make sure it is connected securely?

 

It took a few weeks before I had a chance to try this solution but it did not help. I disconneded the 6-wire plug from the control box and then reconnected it. The display still dies peridocially. The wire plugs underneath the control box appear to fit securely and they do not respond to tapping so I think that that plugs/connections under the control box are not the problem.

 

Does anyone know how to troubleshoot this type of problem? If I had a better understanding of the wiring, I could connect a voltmeter to the appropriate wires and see where the juice is cutting off (when it does) to determine what component is causing the problem. I would connect the voltmeter continuously while the smoker is running so I can monitor for voltage changes when the display goes dead.

 

 

I understand that there is an electical box underneath the smoker. Perhaps this would be a good place to do some testing with the voltmeter. I attached a picture of an MES box I copied off of another posting to show what I mean. I don't know for sure this is the same as inside my own MES40, but it is probably the same.

 

MES Relay.jpg


Edited by hkeiner - 5/1/11 at 8:13pm
post #5 of 5

The hi temp switch she is referring to, should only cut out the heating element, and not the controller.

My limit switch did some funky things when it was very cold outside, but not shut down the entire unit.

 

Did you PM Darryl?

 

 

Todd

No Creosote! A-Maze-N Smokers

Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Electric Smokers
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › MES 40 goes dead intermittantly - Bad controller or overheat sensor?