Problems with Maverick thermometer

Discussion in 'Meat Thermometers' started by johnnie2130, Jun 14, 2008.

  1. johnnie2130

    johnnie2130 Meat Mopper

    I have a Maverick 73 remote thermometer. It seemed to work great the first few times we used it. That was in December and early January. Then it began to be way off on the temps. Maverick sent two new probes recently. After using them they are even more off than the other probes. The smoker temp might be 255 and the Maverick probe shows about 211. We cooked chicken last and I tried cooking according to the temps as usual. When the reading got hot enough to pull the chicken according to the temp chart, the chicken wasn't close to being done. I haven't washed the cords on the new probes. Also, today we put the probes on two different pieces of meat. One showed 130+ and the other showed only 50+.

    Any suggestions on what might be wrong or what to do? Cooking without a reliable thermometer isn't good at all.

    Side note - the remote part worked fine. We could read it almost anywhere in the house. That made it really nice - if it would just work right.
     
  2. johnnie2130

    johnnie2130 Meat Mopper

    Here's another example of how far off the thermometer is. I know you cook by temp, but mine doesn't seem to be working.

    I just took a pork tenderloin off. Usually it takes about two hours to cook. The meat probe showed 128 when we pulled the tenderloin. It's easily done. I've read to pull it at about 145 and then wrap it and put in a cooler. If I had waited until it got to 145 it would be ruined.

    I knew to check it because it had been on for two hours. Now I'm trying to continue cooking a pork butt with a broken thermometer. [​IMG]

    Any suggestions?
     
  3. grillin_all_day

    grillin_all_day Smoking Fanatic SMF Premier Member

    you got me on this. the only advice i have is to keep an old school stick thermometer on hand as a back up.
     
  4. tn_bbq

    tn_bbq Smoking Fanatic

    Keeping a couple thermometers around is always a good idea.

    Seems some of those probe thermometers are a bit quirky at time. I have a couple Accu-rite probe thermometers and that thing is >50 degrees off sometimes. I toss it back in the box and try again the next day...at it works just fine. Go figure.

    Be sure to calibrate your thermometers in boiling water.

    Yours (and mine) might have a little moisture problem.
     
  5. johnnie2130

    johnnie2130 Meat Mopper

    I calibrated it yesterday in boiling water to test it. Both probes went right to 211-212 and stayed there. When I used it for smoking I know it wasn't close to being right.

    If I need a backup thermometer what's a good kind to get that's not too expensive? It doesn't make sense why this one is so quirky though.
     
  6. packplantpath

    packplantpath Smoking Fanatic

    Is it possible the door was closed on the wires causing some kind of problem like this? That sucks.
     
  7. johnnie2130

    johnnie2130 Meat Mopper

    The door was closed and the wires ran from inside the smoker to the outside but it looks like the door has pretty good 'padding' that wouldn't cause it to mess up. It's definitely possible though. I'm not sure how I could check that. It's happened the last few times we've smoked something.
     
  8. johnnie2130

    johnnie2130 Meat Mopper

    I called Maverick and they're sending a new transmitter to see if that's the problem. I have my doubts but we'll see.

    I'm not sure how long the batteries have been in. Do they need to be changed often? They seem to be working ok, but maybe they really aren't.
     

Share This Page