PID doesn't turn on SSR

Discussion in 'Slicers, Grinders, Tools, Equipment' started by wiljm1, Jun 2, 2014.

  1. wiljm1

    wiljm1 Newbie

    I found these mypin ta4 pid's and thought maybe I could use one to control a fan in my smoker, then I stumbled across forum posts from people who have already done this. So with enough confidence from others I ordered the following TA4-RNR and a Amico 250V 25A SSR-25DA to power a transformer to power a fan.

    I wired it all up and I'm confident it's wired correctly. I figured out how to get out to click on and got the temperature reading correctly. My problem is when out clicks on, there's no power at all at the terminals 3 and 4. I tried alarm 1 also with the same result. I hear the controller click on and see the indicator light come on for both, but no power and the SSR doesn't light up. I messed with all sorts of settings.

    After looking at forum posts, it looks like I picked up an RNR and I need an SNR. So I ordered a new one that is a TA4-SNR. I'm not sure what that means but it sounds like SNR has a manual mode. Hopefully it works, however, I still should be getting power at the terminals on the first one I bought, shouldn't I? Am I on the right track here? I've read if you use the wrong SSR on the wrong PID it can burn out the terminals. Maybe the thing just never worked in the first place.

    Any help would be very much appreciated.

    Original PID


    New PID


  2. wiljm1

    wiljm1 Newbie

    I assume the first one was either junk or it's the RNR vs SNR issue I read about. Either way, the new one I ordered works great. This was a great and inexpensive way to build a digital temperature controller.

Share This Page