mes wiring question

Discussion in 'Electric Smokers' started by bowtieracin, Sep 19, 2010.

  1. bowtieracin

    bowtieracin Smoke Blower

    my uncles smoker died it's the 800 watt model we took back cover off last nite and there was only 1 black wire going to the element along with the ground the other terminal was empty. i tthought this odd but it was late and didnt look to hard. now i'm lookin this morning and all pics i see have a wire to each terminal. so do we need to go back in for a second look for a missing wire or are the picss i see of a hotter unit? thanks so much
     
  2. dale5351

    dale5351 Smoking Fanatic

    There should be two wires plus the green grounding wire.  Here is a picture of the back of mine.

    [​IMG]

    And a picture showing how the wires go into the box.

    [​IMG]
     
  3. bowtieracin

    bowtieracin Smoke Blower

    thanks for the reply we went back in and found the second wire burnt off got it fixed up and workin again it didnt want to get up to and hold temp very well.
     
  4. eman

    eman Smoking Guru Staff Member Moderator OTBS Member

    If you have to open a mes to make repairs go ahead and replace all the wires w/ new 12 guage hi temp wiring and new connectors if you can. may save you another trip back into it.
     
  5. bowtieracin

    bowtieracin Smoke Blower

    eman,

     thanks for the headsup we are camping and didn't have everything we needed. but we did have meat that was rubbed an ready so we made do.

    And 3/4 the way thru the last piece it gave out again so off to the stove it went and will be doing an overhaul when we get home!!
     

Share This Page