MES not heating

Discussion in 'Electric Smokers' started by joshs, Jul 23, 2011.

  1. joshs

    joshs Smoke Blower

    I cleaned the sensor in my MES an it still will not heat. Where can I buy the heating element to replace the old one?
     
  2. Check the wires connected to the heating element...they are known to burn off the wire connectors. It is a easy fix just type in MES mods. into our search bar and you should find a thread or three on replacing the connectors. [​IMG]
     
  3. jsdspif

    jsdspif Meat Mopper

    I second looking at the terminals . I know when it happened to mine (before I checked the wires and before I knew this forum ) I spoke to Masterbuilt and the lady seemed quite knowledgable about the unit , she said she had never heard of an element going bad and she doubted that was the problem , but the unit was out of warranty and she referred me to a repair center . Unless the element is broken in half or something very obvious , I doubt it's the element .
     
  4. daveomak

    daveomak Smoking Guru OTBS Member SMF Premier Member

    Check to see that the timer is set. The element will not heat if the time is expired. How do I know........I've done it myself......

    Dave
     
  5. joshs

    joshs Smoke Blower

    Its not with the timer. I to have forgot to set it before. I took the back off, but from what I can see there, the wires look good.
     
    Last edited: Jul 30, 2011
  6. tjohnson

    tjohnson Smoking Guru Staff Member Moderator Insider OTBS Member SMF Premier Member

    Plug and unplug the terminals

    Mine turned yellow and blew

    Never heard of an element going bad

    Could be the controller

    Todd
     
  7. michael ark

    michael ark Master of the Pit

    Don't see why mes guy are so loyal.I see broken mes on here once a week.
     
  8. tjohnson

    tjohnson Smoking Guru Staff Member Moderator Insider OTBS Member SMF Premier Member


    Loyalty Sometimes Boarders on Stupidity

    I've had really good luck for the many hundreds of hours I've put on my (2) MES 40's for smoking meat and testing my gadgets

    Only repair was a burned terminal, but EZ fix

    I remember when there were 5-10 broke down every week!

    Todd
     
  9. joshs

    joshs Smoke Blower

    This was the problem. Thanks for the help guys. I wonder how many get chunked in the trash over this. If not for this site that is probably where mine would have been.
     
  10. bluebombersfan

    bluebombersfan Master of the Pit OTBS Member


    Haven't had any problems with mine yet (knock on wood)
     
  11. roller

    roller Smoking Guru SMF Premier Member

    Some good trouble shooters...
     



  12. Glad you found your problem Josh and got it fixed...This site is full of great people always willing to sharing their recipes and smoking wisdom!!![​IMG]
     
  13. tjohnson

    tjohnson Smoking Guru Staff Member Moderator Insider OTBS Member SMF Premier Member

    GREAT SAVE!

    Todd
     

Share This Page