MES 30 not staying on! Help!

Discussion in 'Electric Smokers' started by uncle bubba, Nov 17, 2015.

  1. uncle bubba

    uncle bubba Newbie

    I bought my MES 30" on New Years Eve, so I've only had it for less then a year.   Glass window in door, and electric display  is on top in the back of the unit.  Is that Gen 1?

    I tried to fire it up last night to smoke some salmon for my wife's school breakfast, but it wouldn't stay on.  Sometimes it would just flash numbers at me and continuously "click", then it would turn on and I could set the temperature, but when I clicked on the timer, it would shut off.   It would also appear to reset itself where the display would flash "8888", then cycle through "0000....0000....0000...1111....1111...1111...2222....2222"  etc. 

    Am I forced to call Masterbuilt for a replacement piece? 

    Couple of other notes, I am in NJ, and last night was about 45 degrees when I tried to turn it on.  Not terribly cold, and I have used it in colder weather.

    Hasn't rained, and I do have it under a cover.

    It is on an extension cord, but I have a Heavy Duty cord that is only 12 feet long.

    Couple of weeks ago I used it, and it would start to heat up, but then after a 10 minutes or so, it would shut off.  I was cooking ribs for a tailgate too, so I ended up losing about an hour of cooking time before it worked properly.

    Any thoughts?
     
    Last edited: Nov 17, 2015
  2. redsmoke

    redsmoke Fire Starter

    Call masterbuilt they have been very helpful. I'm thinking the board is bad.

    Mine gets weird after a rain and it's not covered. The temp should not be a issue. I've ran mine below 0 and no issues.

    Did you try just using the control on the unit with out the remote or just the remote. Hitting the light button will make mine shut off but that is after a rain.
     
  3. bearcarver

    bearcarver Smoking Guru OTBS Member

    I would never allow my MES to be rained on, just like any of my other electric tools.

    Bear
    Yes that is a Gen #1.

    As Redsmoke said, I would call Masterbuilt & tell them what it does. It's no longer under warranty, but I've seen them help others after the warranty was out. They are a good CS Company.

    Also mine works fine down to Zero °. Below Zero, I don't know, because I don't work well below Zero in my old age.

    Bear
     
  4. daveomak

    daveomak Smoking Guru OTBS Member SMF Premier Member

    Did you try unplugging the smoker, from the power source, to reset the electronics...
     
  5. uncle bubba

    uncle bubba Newbie

    Yes I tried unplugging it. 

    I will try Masterbuilt Customer Service....   but I could also just buy a new smoker.  Wife isn't happy about that thought, but she also loves when I cook, so she can't complain too much.
     
  6. bearcarver

    bearcarver Smoking Guru OTBS Member

    I'd give them a chance to help fix it, before you lay out for a New one.

    Keep us posted.

    Bear
     

Share This Page