Maverick ET-732 remote keeps erroring out.

Discussion in 'Slicers, Grinders, Tools, Equipment' started by ddemerath, Feb 6, 2012.

  1. ddemerath

    ddemerath Smoke Blower

    Back in June I was given a Maverick ET-732 remote thermometer set.  I has served me well for the most part til Sunday.   I put a ham in the pellet grill and turned on the Thermometer.  The remote was registering well and took it inside and set it on the counter.  After about 5 minutes it beeped and the screen went blank.  Maybe the battery's were getting bad so I replaced both sets.  Restarted the units and took the remote back inside, same thing again.  This time I pressed the reset and took it back in only to have it fail again.  The sending unit seemed to work just fine.  Am I missing something or has my receiver given up on me.

    Thanks.
     
  2. smokinal

    smokinal Smoking Guru Staff Member Moderator OTBS Member ★ Lifetime Premier ★

    I have had the same problem a couple of times, don't have a clue why. Sometimes it will loose the signal & get it back in a few minutes without me doing anything. Other times I have to walk closer to the smoker & it gets the signal back. Maybe Todd has the answer.
     
  3. oldschoolbbq

    oldschoolbbq Smoking Guru OTBS Member

    Mine did the same the day i got them , then straightened out. I'm thinking it's the transmitter's overhaul for distance, I did find that it doesn't do good through 3 or more walls with siding on them , as Al said, Todd can give yiu a more definitive answer.[​IMG]
     
  4. venture

    venture Smoking Guru OTBS Member

    Mine has just started doing something similar on the last couple of smokes.  So far, it just beeps at me and then straightens up after a few seconds.  More of an irritation than anything.  Might be time for new batteries.

    Good luck and good smoking.
     

Share This Page