Issue on the snack stix...(Revised w.QVIEW)

Discussion in 'Sausage' started by hoity toit, Jan 7, 2012.

  1. hoity toit

    hoity toit Master of the Pit SMF Premier Member

    Made snack stix today like I always do, same mix and everything. Used small sheep casing, everything stuffed ok. Started out at 120 for an hour then added smoke with the AMPS raising the temp10 or so every hour. When the first probe got to 152  I pulled them out and hit the ice bath. It was then I noticed some of the casings werestill white, so I pu them back in again adding more smoke and cranked the temp up to 170. I am at 145 now and watching close so I dont go over the threshold...

    What the heck is going on? To much moisture? I did add a little extra water in the mix to ease stuffing the small casing this time. Top half of the casing looks fine.. its the bottom part thats the problem.

    opinions please..Thanks in advance.

    dexter
     
    Last edited: Jan 8, 2012
  2. raptor700

    raptor700 Master of the Pit OTBS Member

    That does sound strange Dexter, How are you smoking them...........smoke house, MES, etc?
     
  3. nepas

    nepas Smoking Guru Staff Member Moderator Group Lead OTBS Member SMF Premier Member

    White casing after the ice bath is a fat-out. I never keep a probe in while smoking. It acts as a heat sink and causes false readings.
     
  4. hoity toit

    hoity toit Master of the Pit SMF Premier Member


    No,,,they were white when I took them out...Ive done these many times,never had this problem.., I think I added too much water and the top got done but the bottom didnt.
     
  5. boykjo

    boykjo Sausage maker Staff Member Moderator Group Lead OTBS Member

    Can we get some pics to see whats happening

    Joe
     
  6. hoity toit

    hoity toit Master of the Pit SMF Premier Member


    MES like I always do... I added extra waterto ease stuffing. I think thats what happened... They are back in and coming along ok now. I think i will be able to salvage them Ok. look like.
     
  7. hoity toit

    hoity toit Master of the Pit SMF Premier Member


    I added extra water to ease stuffing. I think thats what happened... They are back in and coming along ok now. I think i will be able to salvage them Ok.. Im at 152 nowandgetting ready to pull them out.
     
  8. hoity toit

    hoity toit Master of the Pit SMF Premier Member


    Ill take some pic whenI pull them shortly...
     
  9. nepas

    nepas Smoking Guru Staff Member Moderator Group Lead OTBS Member SMF Premier Member

    water is one added item that will not hurt the sausage, it will just take a bit longer.
     
  10. hoity toit

    hoity toit Master of the Pit SMF Premier Member


    [​IMG]

    [​IMG]
     
  11. hoity toit

    hoity toit Master of the Pit SMF Premier Member


    just put some pics up..
     
  12. raptor700

    raptor700 Master of the Pit OTBS Member

    WOW...never seen that before!
     
  13. hoity toit

    hoity toit Master of the Pit SMF Premier Member

    I got my temp set at 155 now and are putting more smoke to it to see if I can get some color on the ones that are retaining the water.
     
  14. hoity toit

    hoity toit Master of the Pit SMF Premier Member


    Thats what I m thinking too.
     
  15. raptor700

    raptor700 Master of the Pit OTBS Member

    I've never had this problem but water could be the issue
     
  16. hoity toit

    hoity toit Master of the Pit SMF Premier Member

    I just checked it when I took the pictures and my glasses fogged up., Hence I think its still moisture that needs to go away on some of the links.
     
  17. do you have water in your pan?  natural casings have to be dry b4 they will color up
     
  18. hoity toit

    hoity toit Master of the Pit SMF Premier Member


    No water in the pan at all. But I did add some extra water for these casing to make it easier to stuff.  Looks like they are coming along better now.. They have been in for 7 hrs. now. still getting steam out of the stack.Thank you Big C
     
    Last edited: Jan 7, 2012
  19. yeah no problem, I have been through the same thing with my MES they seem like they make water at times almost like they pull the humidity out of the air, also in the picture it looks like it's the ones in the center maybe there just isn't a good air flow in there?
     
  20. hoity toit

    hoity toit Master of the Pit SMF Premier Member


    Thats what im thinking too.. I probably should not have added the extra water., first time Ive done that., maybe added an extra 1/2 cup. gonna let it coast for now at 155 until I see the steam lessen. Thought about cracking the doorsome but dont want to lose the temp. Internals are at around 148-150 somthing like that. 

    Maybe i need to leave that water pan out next time to promote more heat and air flow in the chamber.
     
    Last edited: Jan 8, 2012

Share This Page