First smoke - newbie question

Discussion in 'General Discussion' started by knifebld, Apr 12, 2014.

  1. knifebld

    knifebld Smoking Fanatic

    Hi guys,

    Starting my first smoke and have a few questions....

    I am smoking with a brand new Weber smokey mountain 22.5, I have temp probes in the pork butt and clipped the probe right under the top grill (pork butt is on the top grill).

    Problem is that the factory weber probe is reading 260F and the probe is reading 207F...do i have the probe set at the right spot? Is it normal to have such a large difference in readings?

    Cheers,

    Knife
     
  2. Hello.  A little more info would be helpful.  What kind of therm are you using ( probes )?  Did you test the therm probes before starting the smoke?  Is the chamber probe touching any metal?  Is the clip  properly placed on the probe?  As a "general" rule the answer is yes.  The therms that come with all smokers are notorious for being incorrect.  Not saying your's is one of these but would not be surprised to learn it was off.  Keep Smokin!

    Danny
     
  3. knifebld

    knifebld Smoking Fanatic

    Hey Danny!

    Probe I am using is a Maverick ET-733. It is clipped on right. Changed spots to top rack and clipped on the top (previously had it clipped under and noticed meat juices where dripping on it...oops).

    Temp right now on the weber is at 235F, and temp on the probe is reading 262F.

    Cheers
     
  4. Hello.  Go with the Maverick.  Keep Smokin!

    Danny
     

Share This Page